ramips: add kmod-mt7615e to Xiaomi Mi Router 3 Pro images
authorOzgur Can Leonard <ozgurcan@gmail.com>
Fri, 2 Aug 2019 18:55:41 +0000 (21:55 +0300)
committerDavid Bauer <mail@david-bauer.net>
Fri, 9 Aug 2019 22:32:28 +0000 (00:32 +0200)
Now that the mt76/mt7615e driver is in Openwrt, might as well use it.

Signed-off-by: Ozgur Can Leonard <ozgurcan@gmail.com>
target/linux/ramips/dts/mt7621_xiaomi_mir3p.dts
target/linux/ramips/image/mt7621.mk

index 9800517597b1990957a59ec5aa6eee0fbe085d09..34efb1f6d46ebe60d264c5b238bb30d33e2ff7f2 100644 (file)
 
 &pcie0 {
        wifi@0,0 {
-               compatible = "pci14c3,7615";
+               compatible = "mediatek,mt76";
                reg = <0x0000 0 0 0 0>;
                mediatek,mtd-eeprom = <&factory 0x0000>;
+               ieee80211-freq-limit = <2400000 2500000>;
        };
 };
 
 &pcie1 {
        wifi@0,0 {
-               compatible = "pci14c3,7615";
+               compatible = "mediatek,mt76";
                reg = <0x0000 0 0 0 0>;
                mediatek,mtd-eeprom = <&factory 0x8000>;
                ieee80211-freq-limit = <5000000 6000000>;
index d86eb8cc347351dc3d58670a5b0d68fd3c0ff9dd..d32feb7eabec5919a5cc8a03a09e7678bb4936de 100644 (file)
@@ -669,7 +669,8 @@ define Device/xiaomi_mir3p
   IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
   IMAGE/factory.bin := append-kernel | pad-to $$(KERNEL_SIZE) | append-ubi | check-size $$$$(IMAGE_SIZE)
   DEVICE_PACKAGES := \
-       kmod-usb3 kmod-usb-ledtrig-usbport wpad-basic uboot-envtools
+       kmod-mt7615e kmod-usb3 kmod-usb-ledtrig-usbport wpad-basic \
+       uboot-envtools
 endef
 TARGET_DEVICES += xiaomi_mir3p