gre: remove setting default firewall zone to wan
authorFlorian Eckert <fe@dev.tdt.de>
Thu, 11 Oct 2018 11:10:56 +0000 (13:10 +0200)
committerHans Dedecker <dedeckeh@gmail.com>
Thu, 7 Feb 2019 20:58:07 +0000 (21:58 +0100)
There are two problems with this behaviour that the zone is set to wan
if no zone config option is defined in the interface section.

* The zone for the interface is "normally" specified in the firewall
config file. So if we have defined "no" zone for this interface zone
option is set now to "wan" additonaly if we add the interface in the firewall
config section to the "lan" zone, the interface is added to lan and wan at once.

iptables-save | grep <iface>

This is not what I expect.

* If I do not want to set a zone to this interface it is not possible.

Remove the default assigment to wan if no zone option is defined.
If some one need the option it stil possible to define this option.

Signed-off-by: Florian Eckert <fe@dev.tdt.de>
Signed-off-by: Hans Dedecker <dedeckeh@gmail.com> [PKG_RELEASE increase]
package/network/config/gre/Makefile
package/network/config/gre/files/gre.sh

index a7e8612c6ca8c53ee7e79fd5b13609b231959cb5..6fe6d567b91cd9c9d4c8799d04e1fa6c6a178216 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gre
 PKG_VERSION:=1
-PKG_RELEASE:=9
+PKG_RELEASE:=10
 PKG_LICENSE:=GPL-2.0
 
 include $(INCLUDE_DIR)/package.mk
index ca11e87cfd4502e547d1c255ec25223325d43a40..2bb1010b76aa30ecd07082e81c756089eb1273a3 100755 (executable)
@@ -16,7 +16,6 @@ gre_generic_setup() {
        local mtu ttl tos zone ikey okey icsum ocsum iseqno oseqno multicast
        json_get_vars mtu ttl tos zone ikey okey icsum ocsum iseqno oseqno multicast
 
-       [ -z "$zone" ] && zone="wan"
        [ -z "$multicast" ] && multicast=1
 
        proto_init_update "$link" 1