ath79: add support for Ubiquiti SW devices
authorTobias Schramm <tobleminer@gmail.com>
Tue, 3 Dec 2019 21:39:01 +0000 (22:39 +0100)
committerDavid Bauer <mail@david-bauer.net>
Sun, 12 Jan 2020 13:12:50 +0000 (14:12 +0100)
SW devices are Ubiquit ToughSwitch and EdgeSwitch series devices.
Hardware-wise they are very similar to the XM device series.

Signed-off-by: Tobias Schramm <tobleminer@gmail.com>
target/linux/ath79/image/generic-ubnt.mk

index 05847cc3a2922abfb6d8602f400225b22293d878..f6546f369eb81857ffa01d02a67661a2cced8285 100644 (file)
@@ -47,6 +47,18 @@ define Device/ubnt-bz
   UBNT_VERSION := 6.0.0
 endef
 
+define Device/ubnt-sw
+  $(Device/ubnt)
+  SOC := ar7242
+  DEVICE_PACKAGES += kmod-usb-ohci
+  IMAGE_SIZE := 7552k
+  UBNT_BOARD := SW
+  UBNT_CHIP := ar7240
+  UBNT_TYPE := SW
+  UBNT_VERSION := 1.4.1
+  KERNEL := kernel-bin | append-dtb | relocate-kernel | lzma | uImage lzma
+endef
+
 define Device/ubnt-wa
   $(Device/ubnt)
   SOC := ar9342