rpcd: add respawn param
authorFlorian Eckert <fe@dev.tdt.de>
Thu, 7 Nov 2019 13:31:29 +0000 (14:31 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 22 Dec 2019 23:22:07 +0000 (00:22 +0100)
The rpcd service is an important service, but if the service stops
working for any reason, no one will ever respawn that service. With this
commit, the procd service will monitor if the rpcd service
is running. If the rpcd service has crashed, then
procd respawns the rpcd service.

Signed-off-by: Florian Eckert <fe@dev.tdt.de>
package/system/rpcd/Makefile
package/system/rpcd/files/rpcd.init

index 853554b5a02d47507b0f486f2fe575356b0240b5..653c859ba10927b27b1c843abc7d577ec0401c51 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=rpcd
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL=$(PROJECT_GIT)/project/rpcd.git
index 447133c67a5a639e665fccf8b66efa703760c948..3e9ea5bbf32995625651bc542730ff2822466ef3 100755 (executable)
@@ -12,6 +12,7 @@ start_service() {
 
        procd_open_instance
        procd_set_param command "$PROG" ${socket:+-s "$socket"} ${timeout:+-t "$timeout"}
+       procd_set_param respawn ${respawn_retry:-0}
        procd_close_instance
 }