kernel/modules: add kmod-adcxx module
authorFlorian Eckert <fe@dev.tdt.de>
Tue, 25 Jul 2017 14:38:56 +0000 (16:38 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 9 Jun 2018 20:39:17 +0000 (22:39 +0200)
Add kernel module package for kmod-adcxx.

Signed-off-by: Florian Eckert <fe@dev.tdt.de>
package/kernel/linux/modules/hwmon.mk

index e6dfa73decc502b8e04bb42a836f4b5ed84122b0..5cd849b86d3054c0d42a843bfe97c6e075e187b3 100644 (file)
@@ -427,3 +427,25 @@ endef
 $(eval $(call KernelPackage,hwmon-w83793))
 
 
+define KernelPackage/hwmon-adcxx
+  TITLE:=ADCxx monitoring support
+  KCONFIG:=CONFIG_SENSORS_ADCXX
+  FILES:=$(LINUX_DIR)/drivers/hwmon/adcxx.ko
+  AUTOLOAD:=$(call AutoLoad,60,adcxx)
+  $(call AddDepends/hwmon,)
+endef
+
+define KernelPackage/hwmon-adcxx/description
+  Kernel module for the National Semiconductor
+  ADC<bb><c>S<sss> chip family, where
+  * bb  is the resolution in number of bits (8, 10, 12)
+  * c   is the number of channels (1, 2, 4, 8)
+  * sss is the maximum conversion speed (021 for 200 kSPS, 051 for 500
+    kSPS and 101 for 1 MSPS)
+
+  Examples : ADC081S101, ADC124S501, ...
+endef
+
+$(eval $(call KernelPackage,hwmon-adcxx))
+
+