mwlwifi: Fix loading with backports v5.3
authorBoris Krasnovskiy <boris.krasnovskiy@lairdtech.com>
Sun, 18 Aug 2019 00:04:00 +0000 (20:04 -0400)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 18 Aug 2019 12:06:14 +0000 (14:06 +0200)
This adds a vendor command policy which is enforced since mac80211 from
kernel 5.3

Fixes: 928e893a11db ("mac80211: Update to version 5.3-rc4-1")
Signed-off-by: Boris Krasnovskiy <boris.krasnovskiy@lairdtech.com>
package/kernel/mwlwifi/Makefile
package/kernel/mwlwifi/patches/001-vendor_command_policy.patch [new file with mode: 0644]

index 642d80083633812dd834a1e450d0e79d2d7aeeeb..aa8eea0450a2e16a460c2f18af1fa6a3dcc07a0c 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mwlwifi
-PKG_RELEASE=1
+PKG_RELEASE=2
 
 PKG_LICENSE:=ISC
 PKG_LICENSE_FILES:=
diff --git a/package/kernel/mwlwifi/patches/001-vendor_command_policy.patch b/package/kernel/mwlwifi/patches/001-vendor_command_policy.patch
new file mode 100644 (file)
index 0000000..1f06d55
--- /dev/null
@@ -0,0 +1,19 @@
+mac80211 from kernel 5.3 and later checks the new policy attribute.
+
+--- a/vendor_cmd.c
++++ b/vendor_cmd.c
+@@ -92,12 +92,14 @@ static const struct wiphy_vendor_command
+                         .subcmd = MWL_VENDOR_CMD_SET_BF_TYPE},
+               .flags = WIPHY_VENDOR_CMD_NEED_NETDEV,
+               .doit = mwl_vendor_cmd_set_bf_type,
++              .policy = mwl_vendor_attr_policy,
+       },
+       {
+               .info = { .vendor_id = MRVL_OUI,
+                         .subcmd = MWL_VENDOR_CMD_GET_BF_TYPE},
+               .flags = WIPHY_VENDOR_CMD_NEED_NETDEV,
+               .doit = mwl_vendor_cmd_get_bf_type,
++              .policy = mwl_vendor_attr_policy,
+       }
+ };