ath79: add support for Ubiquiti SW devices
[openwrt/.git] / target / linux / ath79 / image / generic-ubnt.mk
index 05847cc3a2922abfb6d8602f400225b22293d878..f6546f369eb81857ffa01d02a67661a2cced8285 100644 (file)
@@ -47,6 +47,18 @@ define Device/ubnt-bz
   UBNT_VERSION := 6.0.0
 endef
 
+define Device/ubnt-sw
+  $(Device/ubnt)
+  SOC := ar7242
+  DEVICE_PACKAGES += kmod-usb-ohci
+  IMAGE_SIZE := 7552k
+  UBNT_BOARD := SW
+  UBNT_CHIP := ar7240
+  UBNT_TYPE := SW
+  UBNT_VERSION := 1.4.1
+  KERNEL := kernel-bin | append-dtb | relocate-kernel | lzma | uImage lzma
+endef
+
 define Device/ubnt-wa
   $(Device/ubnt)
   SOC := ar9342