package/ethtool: add ethtool
authoracoul <alex@ozo.com>
Thu, 31 Mar 2016 05:03:01 +0000 (08:03 +0300)
committeracoul <alex@ozo.com>
Thu, 31 Mar 2016 05:28:36 +0000 (08:28 +0300)
package/network/services/ethtool/Config.in [new file with mode: 0644]
package/network/services/ethtool/Makefile [new file with mode: 0644]

diff --git a/package/network/services/ethtool/Config.in b/package/network/services/ethtool/Config.in
new file mode 100644 (file)
index 0000000..7ec5553
--- /dev/null
@@ -0,0 +1,7 @@
+menu "Configuration"
+       depends on PACKAGE_ethtool
+
+       config ETHTOOL_PRETTY_DUMP
+               bool "Enable pretty printing"
+
+endmenu
diff --git a/package/network/services/ethtool/Makefile b/package/network/services/ethtool/Makefile
new file mode 100644 (file)
index 0000000..1107654
--- /dev/null
@@ -0,0 +1,57 @@
+#
+# Copyright (C) 2006-2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=ethtool
+PKG_VERSION:=4.2
+PKG_RELEASE:=1
+
+PKG_MAINTAINER:=Matthias Schiffer <mschiffer@universe-factory.net>
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
+PKG_SOURCE_URL:=@KERNEL/software/network/ethtool
+PKG_MD5SUM:=8433e71a256678d859ecc264132063c5
+
+PKG_LICENSE:=GPL-2.0
+PKG_LICENSE_FILES:=COPYING
+
+PKG_FIXUP:=autoreconf
+PKG_INSTALL:=1
+PKG_BUILD_PARALLEL:=1
+
+PKG_CONFIG_DEPENDS:=ETHTOOL_PRETTY_DUMP
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/ethtool
+  SECTION:=net
+  CATEGORY:=Network
+  TITLE:=Display or change ethernet card settings
+  URL:=http://www.kernel.org/pub/software/network/ethtool/
+endef
+
+define Package/ethtool/description
+ ethtool is a small utility for examining and tuning your ethernet-based
+ network interface
+endef
+
+define Package/ethtool/config
+       source "$(SOURCE)/Config.in"
+endef
+
+ifeq ($(CONFIG_ETHTOOL_PRETTY_DUMP),y)
+CONFIGURE_ARGS += --enable-pretty-dump
+else
+CONFIGURE_ARGS += --disable-pretty-dump
+endif
+
+define Package/ethtool/install
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/ethtool $(1)/usr/sbin
+endef
+
+$(eval $(call BuildPackage,ethtool))