oxnas: set ubifs parameters for Default profile
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 23 Mar 2016 12:52:05 +0000 (12:52 +0000)
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 23 Mar 2016 12:52:05 +0000 (12:52 +0000)
Work-around obsolete mkfs/ubifs code.
Unlike squashfs, ubifs images should be generated per-device so
minimum I/O unit size, logical erase block size, maximum logical erase
block count can be defined for the specific flash-chips parameters.
Also, generating ubinized images is unrelated to rootfs being ubifs or
squashfs, but rather depends on the device supporting UBI or not.
In the meantime and in order to fix an error which currently causes the
image generation on buildbot to fail, work-around by defining
UBIFS_OPTS for the Default profile.
See also
http://buildbot.openwrt.org:8010/builders/oxnas/builds/246/steps/compile_8/logs/stdio

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@49068 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/oxnas/image/Makefile

index 548fa62da4f8faf6c56246b3c52bdb2f1bf80d53..ae1050e9a17e441a25b7a7d952b33ca6113ded49 100644 (file)
@@ -8,6 +8,7 @@
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
 
+Default_UBIFS_OPTS = -m 2048 -e 126KiB -c 4096
 STG212_UBIFS_OPTS = -m 2048 -e 126KiB -c 4096
 KD20_UBIFS_OPTS = -m 2048 -e 126KiB -c 4096
 POGOPLUG_PRO_UBIFS_OPTS = -m 2048 -e 126KiB -c 4096