hostap-driver: fix for 3.18 kernel tree ozonet
authorAlexandros Couloumbis <alex@ozo.com>
Wed, 15 Apr 2020 14:23:24 +0000 (17:23 +0300)
committerAlexandros Couloumbis <alex@ozo.com>
Wed, 15 Apr 2020 14:23:24 +0000 (17:23 +0300)
package/kernel/hostap-driver/Makefile

index 3ee0de3fc5f9608576b331c9c1e3a170a73c54dd..feec1bb8dfe1a5e8ee137f8dcf73a8bfcea22353 100644 (file)
@@ -34,12 +34,21 @@ endef
 define KernelPackage/hostap
 $(call KernelPackage/hostap/Default)
   TITLE:=Host AP support for Prism2/2.5/3
-  DEPENDS:=@PCI_SUPPORT||PCMCIA_SUPPORT +kmod-lib80211 +wireless-tools
+  DEPENDS:=@PCI_SUPPORT||PCMCIA_SUPPORT +kmod-lib80211 +wireless-tools @!LINUX_3_18
   KCONFIG:=CONFIG_HOSTAP CONFIG_HOSTAP_FIRMWARE=y CONFIG_HOSTAP_FIRMWARE_NVRAM=y CONFIG_WLAN_VENDOR_INTERSIL=y
   FILES:=$(LINUX_DIR)/drivers/net/wireless/intersil/hostap/hostap.ko
   AUTOLOAD:=$(call AutoProbe,hostap)
 endef
 
+define KernelPackage/hostap
+$(call KernelPackage/hostap/Default)
+  TITLE:=Host AP support for Prism2/2.5/3
+  DEPENDS:=@PCI_SUPPORT||PCMCIA_SUPPORT +kmod-lib80211 +wireless-tools @LINUX_3_18
+  KCONFIG:=CONFIG_HOSTAP CONFIG_HOSTAP_FIRMWARE=y CONFIG_HOSTAP_FIRMWARE_NVRAM=y CONFIG_WLAN_VENDOR_INTERSIL=y
+  FILES:=$(LINUX_DIR)/drivers/net/wireless/hostap/hostap.ko
+  AUTOLOAD:=$(call AutoProbe,hostap)
+endef
+
 define KernelPackage/hostap/description
 $(call KernelPackage/hostap/Default/description)
  This package contains the base Host AP driver code that is shared by 
@@ -51,12 +60,21 @@ endef
 define KernelPackage/hostap-cs
 $(call KernelPackage/hostap/Default)
   TITLE:=Host AP driver for PCMCIA adaptors
-  DEPENDS:=@PCMCIA_SUPPORT +kmod-hostap +kmod-pcmcia-core
+  DEPENDS:=@PCMCIA_SUPPORT +kmod-hostap +kmod-pcmcia-core @!LINUX_3_18
   KCONFIG:=CONFIG_HOSTAP_CS
   FILES:=$(LINUX_DIR)/drivers/net/wireless/intersil/hostap/hostap_cs.ko
   AUTOLOAD:=$(call AutoProbe,hostap_cs)
 endef
 
+define KernelPackage/hostap-cs
+$(call KernelPackage/hostap/Default)
+  TITLE:=Host AP driver for PCMCIA adaptors
+  DEPENDS:=@PCMCIA_SUPPORT +kmod-hostap +kmod-pcmcia-core @LINUX_3_18
+  KCONFIG:=CONFIG_HOSTAP_CS
+  FILES:=$(LINUX_DIR)/drivers/net/wireless/hostap/hostap_cs.ko
+  AUTOLOAD:=$(call AutoProbe,hostap_cs)
+endef
+
 define KernelPackage/hostap-cs/description
 $(call KernelPackage/hostap/Default/description)
  This package contains the Host AP driver for Prism2/2.5/3 PC cards.
@@ -66,12 +84,21 @@ endef
 define KernelPackage/hostap-pci
 $(call KernelPackage/hostap/Default)
   TITLE:=Host AP driver for PCI adaptors
-  DEPENDS:=@PCI_SUPPORT +kmod-hostap
+  DEPENDS:=@PCI_SUPPORT +kmod-hostap @!LINUX_3_18
   KCONFIG:=CONFIG_HOSTAP_PCI
   FILES:=$(LINUX_DIR)/drivers/net/wireless/intersil/hostap/hostap_pci.ko
   AUTOLOAD:=$(call AutoProbe,hostap_pci)
 endef
 
+define KernelPackage/hostap-pci
+$(call KernelPackage/hostap/Default)
+  TITLE:=Host AP driver for PCI adaptors
+  DEPENDS:=@PCI_SUPPORT +kmod-hostap @LINUX_3_18
+  KCONFIG:=CONFIG_HOSTAP_PCI
+  FILES:=$(LINUX_DIR)/drivers/net/wireless/hostap/hostap_pci.ko
+  AUTOLOAD:=$(call AutoProbe,hostap_pci)
+endef
+
 define KernelPackage/hostap-pci/description
 $(call KernelPackage/hostap/Default/description)
  This package contains the Host AP driver for Prism2.5 PCI adaptors.
@@ -81,12 +108,21 @@ endef
 define KernelPackage/hostap-plx
 $(call KernelPackage/hostap/Default)
   TITLE:=Host AP driver for PLX9052 based PCI adaptors
-  DEPENDS:=@PCI_SUPPORT +kmod-hostap
+  DEPENDS:=@PCI_SUPPORT +kmod-hostap @!LINUX_3_18
   KCONFIG:=CONFIG_HOSTAP_PLX
   FILES:=$(LINUX_DIR)/drivers/net/wireless/intersil/hostap/hostap_plx.ko
   AUTOLOAD:=$(call AutoProbe,hostap_plx)
 endef
 
+define KernelPackage/hostap-plx
+$(call KernelPackage/hostap/Default)
+  TITLE:=Host AP driver for PLX9052 based PCI adaptors
+  DEPENDS:=@PCI_SUPPORT +kmod-hostap @LINUX_3_18
+  KCONFIG:=CONFIG_HOSTAP_PLX
+  FILES:=$(LINUX_DIR)/drivers/net/wireless/hostap/hostap_plx.ko
+  AUTOLOAD:=$(call AutoProbe,hostap_plx)
+endef
+
 define KernelPackage/hostap-plx/description
 $(call KernelPackage/hostap/Default/description)
  This package contains the Host AP driver for Prism2/2.5/3 in PLX9052