BB: fix subject in generated certificates
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 25 Jan 2015 23:56:05 +0000 (23:56 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 25 Jan 2015 23:56:05 +0000 (23:56 +0000)
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Backport of r44149

git-svn-id: svn://svn.openwrt.org/openwrt/branches/barrier_breaker@44152 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/utils/px5g/Makefile
package/utils/px5g/px5g.c

index df2a170d8452bd98aa59cb8abc2cd0bf97f44bec..8677a8b1743c77109b455b56fcc4631288322123 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2010-2014 Jo-Philipp Wich <xm@subsignal.org>
+# Copyright (C) 2010-2015 Jo-Philipp Wich <jow@openwrt.org>
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,9 +8,8 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=px5g
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
-PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)
 PKG_USE_MIPS16:=0
 
 include $(INCLUDE_DIR)/package.mk
@@ -19,7 +18,7 @@ define Package/px5g
   SECTION:=utils
   CATEGORY:=Utilities
   TITLE:=X.509 certificate generator (using PolarSSL)
-  MAINTAINER:=Jo-Philipp Wich <xm@subsignal.org>
+  MAINTAINER:=Jo-Philipp Wich <jow@openwrt.org>
   DEPENDS:=+libpolarssl
 endef
 
index 633aa51361e825d2c9ed5e674abc3ddec1811a34..eec8fd3f514864dac98aaa15e45547d37fec12be 100644 (file)
@@ -188,7 +188,7 @@ int selfsigned(char **arg)
                                }
                                memcpy(newc, oldc, delim - oldc);
                                newc += delim - oldc;
-                               *newc++ = ';';
+                               *newc++ = ',';
                                oldc = delim + 1;
                        } while(*delim);
                        arg++;