lantiq: generate unique ARV7519RW22 firmware
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 1 Sep 2014 13:21:25 +0000 (13:21 +0000)
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 1 Sep 2014 13:21:25 +0000 (13:21 +0000)
Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
Backport of r42183

git-svn-id: svn://svn.openwrt.org/openwrt/branches/barrier_breaker@42362 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/lantiq/dts/ARV7519RW22.dts [moved from target/linux/lantiq/dts/ARV7519RW.dtsi with 95% similarity]
target/linux/lantiq/dts/ARV7519RWV11.dts [deleted file]
target/linux/lantiq/dts/ARV7519RWV12.dts [deleted file]
target/linux/lantiq/image/Makefile
target/linux/lantiq/xrx200/profiles/arv.mk

similarity index 95%
rename from target/linux/lantiq/dts/ARV7519RW.dtsi
rename to target/linux/lantiq/dts/ARV7519RW22.dts
index d2d083f8709a905d9ea4933317c4a4686fa4346c..68237532b4d101ada7832383ec425698a7cf77da 100644 (file)
@@ -1,3 +1,5 @@
+/dts-v1/;
+
 /include/ "vr9.dtsi"
 
 / {
                };
        };
 
+       gphy-xrx200 {
+               compatible = "lantiq,phy-xrx200";
+               firmware1 = "lantiq/vr9_phy22f_a1x.bin";        /*VR9 1.1*/
+               firmware2 = "lantiq/vr9_phy22f_a2x.bin";        /*VR9 1.2*/
+               phys = [ 00 01 ];
+       };
+
        gpio-keys-polled {
                compatible = "gpio-keys-polled";
                #address-cells = <1>;
diff --git a/target/linux/lantiq/dts/ARV7519RWV11.dts b/target/linux/lantiq/dts/ARV7519RWV11.dts
deleted file mode 100644 (file)
index 7dadf14..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
-/dts-v1/;
-
-/include/ "ARV7519RW.dtsi"
-
-/ {
-       gphy-xrx200 {
-               compatible = "lantiq,phy-xrx200";
-               firmware = "lantiq/vr9_phy22f_a1x.bin"; /*VR9 1.1*/
-               phys = [ 00 01 ];
-       };
-};
diff --git a/target/linux/lantiq/dts/ARV7519RWV12.dts b/target/linux/lantiq/dts/ARV7519RWV12.dts
deleted file mode 100644 (file)
index 0dd7972..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
-/dts-v1/;
-
-/include/ "ARV7519RW.dtsi"
-
-/ {
-       gphy-xrx200 {
-               compatible = "lantiq,phy-xrx200";
-               firmware = "lantiq/vr9_phy22f_a2x.bin"; /*VR9 1.2*/
-               phys = [ 00 01 ];
-       };
-};
index 768b227e625812d1d790713cbab4431460ae29cc..5c96b632f87f07e4df5db25b41f1a2bcaaaa2033 100644 (file)
@@ -401,11 +401,8 @@ Image/BuildKernel/Profile/P2812HNUFX=$(call Image/BuildKernel/Template,P2812HNUF
 Image/InstallKernel/Template/P2812HNUFX=$(call Image/InstallKernel/Template,P2812HNUFX)
 Image/Build/Profile/P2812HNUFX=$(call Image/Build/$(1),$(1),P2812HNUFX)
 
-Image/BuildKernel/Profile/ARV7519RWV11=$(call Image/BuildKernel/Template,ARV7519RWV11,$(1))
-Image/Build/Profile/ARV7519RWV11=$(call Image/Build/$(1),$(1),ARV7519RWV11)
-
-Image/BuildKernel/Profile/ARV7519RWV12=$(call Image/BuildKernel/Template,ARV7519RWV12,$(1))
-Image/Build/Profile/ARV7519RWV12=$(call Image/Build/$(1),$(1),ARV7519RWV12)
+Image/BuildKernel/Profile/ARV7519RW22=$(call Image/BuildKernel/Template,ARV7519RW22,$(1))
+Image/Build/Profile/ARV7519RW22=$(call Image/Build/$(1),$(1),ARV7519RW22)
 
 Image/BuildKernel/Profile/EASY80920NAND=$(call Image/BuildKernel/Template,EASY80920NAND)
 Image/Build/Profile/EASY80920NAND=$(call Image/Build/$(1),$(1),EASY80920NAND)
index 776bf49a0a151b144e48671f1735a7df7bc5ddc6..821884cb407f57e7aa4578e88b6cbe8eae17faa9 100644 (file)
@@ -36,22 +36,12 @@ endef
 
 $(eval $(call Profile,VGV7519BRN))
 
-define Profile/ARV7519RWV11
-  NAME:=Livebox Astoria ARV7519 v1.1
+define Profile/ARV7519RW22
+  NAME:=Livebox Astoria ARV7519RW22
   PACKAGES:=kmod-ltq-deu-vr9 kmod-ltq-hcd-vr9 \
        kmod-ltq-vdsl-vr9-mei kmod-ltq-vdsl-vr9 \
        kmod-ltq-atm-vr9 ltq-vdsl-vr9-fw-installer \
        ltq-vdsl-app ppp-mod-pppoa
 endef
 
-$(eval $(call Profile,ARV7519RWV11))
-
-define Profile/ARV7519RWV12
-  NAME:=Livebox Astoria ARV7519 v1.2
-  PACKAGES:=kmod-ltq-deu-vr9 kmod-ltq-hcd-vr9 \
-       kmod-ltq-vdsl-vr9-mei kmod-ltq-vdsl-vr9 \
-       kmod-ltq-atm-vr9 ltq-vdsl-vr9-fw-installer \
-       ltq-vdsl-app ppp-mod-pppoa
-endef
-
-$(eval $(call Profile,ARV7519RWV12))
+$(eval $(call Profile,ARV7519RW22))