imagebuilder: remove postinst files before generating image
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 31 Aug 2014 11:06:48 +0000 (11:06 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 31 Aug 2014 11:06:48 +0000 (11:06 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
Backport of r42339

git-svn-id: svn://svn.openwrt.org/openwrt/branches/barrier_breaker@42340 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/imagebuilder/files/Makefile

index 222dac43cc84d95326095c6289f0973cb9005216..72a91e074053fd5bafa05ee43c4b5c231557b681 100644 (file)
@@ -149,6 +149,7 @@ package_postinst: FORCE
                        IPKG_INSTROOT=$(TARGET_DIR) $(which bash) ./etc/rc.common $$script enable; \
                done || true; \
        )
+       rm -f $(TARGET_DIR)/usr/lib/opkg/info/*.postinst
        $(if $(CONFIG_CLEAN_IPKG),rm -rf $(TARGET_DIR)/usr/lib/opkg)
 
 build_image: FORCE