[hotplug2] add hotplug2 v1.0
authorhcg <hcg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 28 May 2009 13:21:58 +0000 (13:21 +0000)
committerhcg <hcg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 28 May 2009 13:21:58 +0000 (13:21 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@16136 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/hotplug2/Makefile [new file with mode: 0644]
package/hotplug2/files/hotplug2.rules [new file with mode: 0644]

diff --git a/package/hotplug2/Makefile b/package/hotplug2/Makefile
new file mode 100644 (file)
index 0000000..03ee608
--- /dev/null
@@ -0,0 +1,50 @@
+#
+# Copyright (C) 2006-2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=hotplug2
+PKG_REV:=198
+PKG_VERSION:=$(PKG_REV)
+PKG_RELEASE:=3
+
+PKG_SOURCE_PROTO:=svn
+PKG_SOURCE_VERSION:=$(PKG_REV)
+PKG_SOURCE_SUBDIR:=hotplug2-$(PKG_VERSION)
+PKG_SOURCE_URL:=http://svn.nomi.cz/svn/isteve/hotplug2 
+PKG_SOURCE:=$(PKG_SOURCE_SUBDIR).tar.gz
+#PKG_SOURCE_URL:=http://isteve.bofh.cz/~isteve/hotplug2
+#PKG_MD5SUM:=ea2c01d027b4002e4e6b0ff266f51a51
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/hotplug2
+  SECTION:=base
+  CATEGORY:=Base system
+  VERSION:=1.0-beta-$(PKG_RELEASE)
+  TITLE:=Version 1.0 Dynamic device management subsystem for embedded systems
+  URL:=http://isteve.bofh.cz/~isteve/hotplug2/
+endef
+
+define Package/hotplug2/description
+ Hotplug2 is a trivial replacement of some of the UDev functionality
+ in a tiny pack, intended for Linux early userspace: Init RAM FS and InitRD.
+ This is an implementation of Hotplug2-1.0-beta
+endef
+
+MAKE_FLAGS += CFLAGS="$(TARGET_CFLAGS) -DHAVE_RULES -I."
+
+define Package/hotplug2/install
+       $(INSTALL_DIR) $(1)/etc
+       $(INSTALL_DATA) ./files/hotplug2.rules $(1)/etc/
+       $(INSTALL_DIR) $(1)/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/hotplug2 $(1)/sbin/
+       $(INSTALL_DIR) $(1)/lib/hotplug2
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/workers/worker_fork.so $(1)/lib/hotplug2
+endef
+
+$(eval $(call BuildPackage,hotplug2))
diff --git a/package/hotplug2/files/hotplug2.rules b/package/hotplug2/files/hotplug2.rules
new file mode 100644 (file)
index 0000000..8ad8103
--- /dev/null
@@ -0,0 +1,10 @@
+$include /etc/hotplug2-common.rules
+
+SUBSYSTEM ~~ (net|button|usb|platform|ieee1394|block) {
+       exec /sbin/hotplug-call %SUBSYSTEM%
+}
+
+DEVICENAME ~~ (watchdog) {
+       exec /sbin/watchdog -t 5 /dev/watchdog
+       next
+}