move ccache to tools/ and fix potential dependency issue
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 27 Feb 2007 23:46:34 +0000 (23:46 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 27 Feb 2007 23:46:34 +0000 (23:46 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6413 3c298f89-4303-0410-b956-a3cf2f4a3e73

toolchain/Makefile
tools/Makefile
tools/ccache/Makefile [moved from toolchain/ccache/Makefile with 100% similarity]

index 4832a657dfa474635da6da839e49cb9f31bc1d47..7773c32c314d094fb0e56cfdc25b3d75a51b0dd7 100644 (file)
@@ -10,7 +10,6 @@ include $(TOPDIR)/rules.mk
 
 TARGETS-y:=kernel-headers
 TARGETS-$(CONFIG_GDB) += gdb
-TARGETS-$(CONFIG_CCACHE) += ccache
 ifeq ($(CONFIG_NATIVE_TOOLCHAIN),)
   TARGETS-y+=binutils gcc uClibc
 endif
index d03ab38ee38343a86f6c61dc4451a5c8874ffa8e..8c5f699d321134f03159219ded77a92f97f58d69 100644 (file)
@@ -8,6 +8,7 @@
 #
 include $(TOPDIR)/rules.mk
 TARGETS-y:=sed sstrip ipkg-utils ext2fs squashfs mtd-utils lzma mkimage firmware-utils
+TARGETS-$(CONFIG_CCACHE) += ccache
 
 TARGETS_DOWNLOAD:=$(patsubst %,%-download,$(TARGETS-y))
 TARGETS_PREPARE:=$(patsubst %,%-prepare,$(TARGETS-y))
@@ -28,7 +29,7 @@ ifneq ($(shell $(SCRIPT_DIR)/timestamp.pl -p . $(STAMP)),$(STAMP))
   $(STAMP): $(TARGETS_INSTALL)
 endif
 
-$(STAMP):
+$(STAMP): $(TOPDIR)/.config
        mkdir -p $(shell dirname $@)
        touch $@