only build avr32 u-boot if requested, fixes build failure in default config
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 5 Aug 2008 01:01:27 +0000 (01:01 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 5 Aug 2008 01:01:27 +0000 (01:01 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@12116 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/avr32/image/Makefile

index 2cef2653bf1db6b0d3554e74219fc9b42346bb5a..c74efbe1df71f0dc5b97017924062258ff6f3261 100644 (file)
@@ -8,13 +8,15 @@
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
 
-define Build/Clean
+ifneq ($(CONFIG_AVR32_UBOOT),)
+  define Build/Clean
        $(MAKE) -C u-boot clean
-endef
+  endef
 
-define Build/Compile
+  define Build/Compile
        $(MAKE) -C u-boot compile
-endef
+  endef
+endif
 
 define Image/Prepare
        cp $(LINUX_DIR)/arch/avr32/boot/images/uImage $(KDIR)/uImage