change DEBUG_DIR to DEBUG_SCOPE_DIR (to avoid conflict with rules.mk)
authorralph <ralph@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 20 Feb 2009 10:30:21 +0000 (10:30 +0000)
committerralph <ralph@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 20 Feb 2009 10:30:21 +0000 (10:30 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14575 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/debug.mk

index 68d70ba093357f799a87ccc3a5121c80f8fa462c..faead042dc4a81909cef3689b94f9a11b367ad74 100644 (file)
@@ -22,7 +22,7 @@ ifeq ($(DUMP),)
 endif
 
 define debug
-$$(findstring $(2),$$(if $$(DEBUG_DIR),$$(if $$(filter $$(DEBUG_DIR)%,$(1)),$(build_debug)),$(build_debug)))
+$$(findstring $(2),$$(if $$(DEBUG_SCOPE_DIR),$$(if $$(filter $$(DEBUG_SCOPE_DIR)%,$(1)),$(build_debug)),$(build_debug)))
 endef
 
 define warn