libuuid: only build the static variant - fixes compile on mac os x
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 16 Jan 2010 00:11:38 +0000 (00:11 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 16 Jan 2010 00:11:38 +0000 (00:11 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@19157 3c298f89-4303-0410-b956-a3cf2f4a3e73

tools/libuuid/Makefile

index 4e6602e4884b3569b9e70690d40e37f9622d2eaf..f15a87a935e057cf00dbd7f871b733df64761017 100644 (file)
@@ -32,18 +32,18 @@ define Host/Configure
 endef
 
 define Host/Compile
-       $(MAKE) -C $(HOST_BUILD_DIR)/lib/uuid
+       $(MAKE) -C $(HOST_BUILD_DIR)/lib/uuid libuuid.a
 endef
 
 define Host/Install
        $(INSTALL_DIR) $(STAGING_DIR_HOST)/{lib,include/uuid}
        $(CP) $(HOST_BUILD_DIR)/lib/uuid/uuid.h $(STAGING_DIR_HOST)/include/uuid/
-       $(CP) $(HOST_BUILD_DIR)/lib/uuid/libuuid.{so*,a} $(STAGING_DIR_HOST)/lib/
+       $(CP) $(HOST_BUILD_DIR)/lib/uuid/libuuid.a $(STAGING_DIR_HOST)/lib/
 endef
 
 define Host/Clean
        rm -f $(STAGING_DIR_HOST)/include/uuid/uuid.h
-       rm -f $(STAGING_DIR_HOST)/lib/uuid/libuuid.{so*,a}
+       rm -f $(STAGING_DIR_HOST)/lib/uuid/libuuid.*
        $(call Host/Clean/Default)
 endef