libpcap: fix kernel version check
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 21 Aug 2009 22:32:14 +0000 (22:32 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 21 Aug 2009 22:32:14 +0000 (22:32 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@17349 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/libpcap/Makefile

index eef5ff06403ada72c3f7ad9140c4b93578bbdc47..e54950002d5c06ea39798a19335a12d0c544cf88 100644 (file)
@@ -16,6 +16,7 @@ PKG_SOURCE_URL:=http://www.tcpdump.org/release/
 PKG_MD5SUM:=9ad1358c5dec48456405eac197a46d3d
 
 include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/kernel.mk
 
 define Package/libpcap
   SECTION:=libs
@@ -48,6 +49,9 @@ endef
 TARGET_CFLAGS += \
        -ffunction-sections -fdata-sections
 
+CONFIGURE_VARS += \
+       ac_cv_linux_vers=$(LINUX_VERSION)
+
 CONFIGURE_ARGS += \
        --enable-shared \
        --enable-static \