[ar71xx] increase size of the kernel partition on the TEW-632BR board
authorjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 11 Jul 2009 17:15:30 +0000 (17:15 +0000)
committerjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 11 Jul 2009 17:15:30 +0000 (17:15 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@16784 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ar71xx/files/arch/mips/ar71xx/mach-tew-632brp.c
target/linux/ar71xx/image/Makefile

index c3fc2b212d2a2d77f8dbc78a584e267b65a71afb..afb8ceebd508412eafd0bdcdb4eb42d86dc79d0a 100644 (file)
@@ -44,11 +44,11 @@ static struct mtd_partition tew_632brp_partitions[] = {
        } , {
                .name           = "kernel",
                .offset         = 0x030000,
-               .size           = 0x0c0000,
+               .size           = 0x0d0000,
        } , {
                .name           = "rootfs",
-               .offset         = 0x0f0000,
-               .size           = 0x300000,
+               .offset         = 0x100000,
+               .size           = 0x2f0000,
        } , {
                .name           = "art",
                .offset         = 0x3f0000,
index 17d20dfa50765ee8c85eae54bbcb67e603601e1e..b4e433e9c434dd3b3281d61953398bfca1bab80e 100644 (file)
@@ -61,9 +61,9 @@ define Image/Build/AP81
        cp $(KDIR)/vmlinux $(KDIR)/vmlinux-$(2)
        $(STAGING_DIR_HOST)/bin/patch-cmdline $(KDIR)/vmlinux-$(2) '$(strip $(3))'
        $(STAGING_DIR_HOST)/bin/lzma e $(KDIR)/vmlinux-$(2) $(KDIR)/vmlinux-$(2).bin.lzma
-       if [ `stat -c%s "$(KDIR)/vmlinux-$(2).bin.lzma"` -gt 786432 ]; then \
+       if [ `stat -c%s "$(KDIR)/vmlinux-$(2).bin.lzma"` -gt 851968 ]; then \
                echo "Warning: $(KDIR)/vmlinux-$(2).bin.lzma is too big"; \
-       else if [ `stat -c%s $(KDIR)/root.$(1)` -gt 3080192 ]; then \
+       else if [ `stat -c%s $(KDIR)/root.$(1)` -gt 3014656 ]; then \
                echo "Warning: $(KDIR)/root.$(1) is too big"; \
        else \
                mkimage -A mips -O linux -T kernel -a 0x80060000 -C lzma -e \
@@ -71,8 +71,8 @@ define Image/Build/AP81
                        -n 'MIPS OpenWrt Linux-$(LINUX_VERSION)' \
                        -d $(KDIR)/vmlinux-$(2).bin.lzma $(KDIR)/vmlinux-$(2).uImage; \
                ( \
-                       dd if=$(KDIR)/vmlinux-$(2).uImage bs=768k conv=sync; \
-                       dd if=$(KDIR)/root.$(1) bs=3008k conv=sync; \
+                       dd if=$(KDIR)/vmlinux-$(2).uImage bs=832k conv=sync; \
+                       dd if=$(KDIR)/root.$(1) bs=2944k conv=sync; \
                        echo -n $(4); \
                ) > $(call imgname,$(1),$(2)).uni; \
        fi; fi