Fix the stage2 compilation, no side effect with gcc4 (#2190)
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 13 Aug 2007 16:26:58 +0000 (16:26 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 13 Aug 2007 16:26:58 +0000 (16:26 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@8409 3c298f89-4303-0410-b956-a3cf2f4a3e73

toolchain/gcc/Makefile

index cd18098e9fb5d2cc4aaa1e9f1cf8e0d40dfa41d1..bae9220f0c220821101e6e6a0e13d72bc4b71a31 100644 (file)
@@ -93,9 +93,7 @@ define Stage2/Configure
 endef
 
 define Stage2/Compile
-       $(MAKE) -C $(BUILD_DIR2) \
-               SHELL="$(BASH)" \
-               all
+       export SHELL="\$(BASH)"; \$(MAKE) -C \$(BUILD_DIR2) all
 endef
 
 define Stage2/Install