Add a generic Broadcom USB profile.
authoragb <agb@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 31 Mar 2008 08:05:30 +0000 (08:05 +0000)
committeragb <agb@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 31 Mar 2008 08:05:30 +0000 (08:05 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@10695 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/brcm-2.4/profiles/USBGeneric.mk [new file with mode: 0644]

diff --git a/target/linux/brcm-2.4/profiles/USBGeneric.mk b/target/linux/brcm-2.4/profiles/USBGeneric.mk
new file mode 100644 (file)
index 0000000..85bad87
--- /dev/null
@@ -0,0 +1,19 @@
+#
+# Copyright (C) 2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/USBGeneric
+  NAME:=Generic USB
+  PACKAGES:=kmod-brcm-wl kmod-usb-core kmod-usb-ohci kmod-usb2 wlc nas kmod-wlcompat
+endef
+
+define Profile/USBGeneric/Description
+ Package set with for Broadcom routers with USB/USB2 (OHCI/EHCI) support.
+ Includes the WRTSL54GS, WL-520gU, WL-500gP v2, any other BCM5354 routers
+ with USB.
+endef
+$(eval $(call Profile,USBGeneric))
+