install libshared into the staging dir (required by wrt-radauth)
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 5 Aug 2008 22:32:26 +0000 (22:32 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 5 Aug 2008 22:32:26 +0000 (22:32 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@12181 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/broadcom-wl/Makefile

index 04f2960c200e9ff757339c7ba683e6d422e0764e..5db45cdba0beda92701db156a1bfb7dbe884c139 100644 (file)
@@ -165,6 +165,11 @@ define Build/Compile
        $(TARGET_CC) -o $(PKG_BUILD_DIR)/wl $(PKG_BUILD_DIR)/wl_exe.o
 endef
 
        $(TARGET_CC) -o $(PKG_BUILD_DIR)/wl $(PKG_BUILD_DIR)/wl_exe.o
 endef
 
+define Build/InstallDev
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_BUILD_DIR)/router/shared/libshared.a $(1)/usr/lib/
+endef
+
 define Package/wlc/install
        $(CP) ./files/* $(1)/
        $(INSTALL_DIR) $(1)/sbin
 define Package/wlc/install
        $(CP) ./files/* $(1)/
        $(INSTALL_DIR) $(1)/sbin