add a workaround preventing libtool from hardcoding library path in shared libs
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 17 Apr 2009 14:44:50 +0000 (14:44 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 17 Apr 2009 14:44:50 +0000 (14:44 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@15246 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/libtool/Makefile

index 62895a8087a7fc50f89ad22056f2efb2aa05a6e5..324025a295b607b0cd3d8dad8a0652c5b90c0c90 100644 (file)
@@ -41,6 +41,7 @@ define Build/InstallDev
        mv $(2)/include/* $(1)/usr/include/
        $(INSTALL_DIR) $(STAGING_DIR_HOST)/share/aclocal
        $(CP) $(2)/share/aclocal/* $(STAGING_DIR_HOST)/share/aclocal/
+       $(SED) 's,\(hardcode_into_libs\)=yes,\1=no,g' $(2)/bin/libtool
 endef
 
 define Package/libltdl/install