add a simple script for symlinking one tree into another for doing builds with separa...
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 10 Dec 2009 20:52:45 +0000 (20:52 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 10 Dec 2009 20:52:45 +0000 (20:52 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@18734 3c298f89-4303-0410-b956-a3cf2f4a3e73

scripts/symlink-tree.sh [new file with mode: 0755]

diff --git a/scripts/symlink-tree.sh b/scripts/symlink-tree.sh
new file mode 100755 (executable)
index 0000000..8be5f6c
--- /dev/null
@@ -0,0 +1,45 @@
+#!/usr/bin/env bash
+# Create a new openwrt tree with symlinks pointing at the current tree
+# Usage: ./scripts/symlink-tree.sh <destination>
+
+FILES="
+       BSDmakefile
+       Config.in
+       LICENSE
+       Makefile
+       README
+       dl
+       docs
+       feeds.conf.default
+       include
+       package
+       rules.mk
+       scripts
+       target
+       toolchain
+       tools"
+
+if [ -f feeds.conf ] ; then
+       FILES="$FILES feeds.conf"
+fi
+
+if [ -z "$1" ]; then
+       echo "Syntax: $0 <destination>"
+       exit 1
+fi
+
+if [ -e "$1" ]; then
+       echo "Error: $1 already exists"
+       exit 1
+fi
+
+set -e # fail if any commands fails
+mkdir -p dl "$1"
+for file in $FILES; do
+       [ -e "$PWD/$file" ] || {
+               echo "ERROR: $file does not exist in the current tree"
+               exit 1
+       }
+       ln -s "$PWD/$file" "$1/"
+done
+exit 0