[backfire] cleanup: remove refs to unsupported "gemini" target
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 23 Nov 2011 21:44:22 +0000 (21:44 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 23 Nov 2011 21:44:22 +0000 (21:44 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/backfire@29301 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/madwifi/Makefile
toolchain/Config.in
toolchain/gcc/Config.in
toolchain/gcc/Config.version
toolchain/uClibc/config-0.9.30+nptl/arm.gemini [deleted file]
toolchain/uClibc/config-0.9.30.1/arm.gemini [deleted file]
toolchain/uClibc/config-0.9.30.2/arm.gemini [deleted file]
toolchain/uClibc/config-0.9.30.3/arm.gemini [deleted file]

index 3c23245db19f498e6ebe1f62df8e93caa7da05a3..cb5efb60d80139f5a5fd252f4249eb0b27a38245 100644 (file)
@@ -88,9 +88,6 @@ endif
 ifeq ($(ARCH),powerpc)
   HAL_TARGET:=powerpc-be-elf
 endif
-ifeq ($(BOARD),gemini)
-  HAL_TARGET:=armv4-le-elf$(if $(CONFIG_EABI_SUPPORT),gnueabi)
-endif
 ifneq ($(CONFIG_TARGET_atheros),)
   HAL_TARGET:=wisoc
 endif
index aaf4f47006dfc4c5f326c6ae48af776cd83f250e..3975ffdcce8bfa5748f8309f18d7ad91d4771fbc 100644 (file)
@@ -90,7 +90,6 @@ config EABI_SUPPORT
        bool
        depends arm||armeb
        prompt "Enable EABI support" if TOOLCHAINOPTS
-       default n if TARGET_gemini
        default y
        help
          Enable ARM EABI support
index da3745de2757fdfd0f3f883d18cfba10f9de4c2c..55b840099909e442dda0bbcb4b0c029f33d73bb2 100644 (file)
@@ -6,10 +6,9 @@ choice
        default GCC_VERSION_4_2_4 if avr32
        default GCC_VERSION_4_3_3 if powerpc64
        default GCC_VERSION_4_3_3 if TARGET_coldfire
-       default GCC_VERSION_4_3_4 if TARGET_gemini
        default GCC_VERSION_4_4_1 if ubicom32
        default GCC_VERSION_4_3_3_CS if (mips || mipsel) && !(TARGET_octeon || TARGET_sibyte)
-       default GCC_VERSION_4_3_3_CS if (arm || armeb) && !TARGET_gemini
+       default GCC_VERSION_4_3_3_CS if (arm || armeb)
        default GCC_VERSION_4_4_3 if powerpc
        default GCC_VERSION_4_4_3 if (TARGET_octeon || TARGET_sibyte)
        default GCC_VERSION_4_1_2
index 3cfc60ae20d60894ddf58489a6ed1d95f67ffa71..fd4f6905c9a5664922edd15b1c71a1dbe8883315 100644 (file)
@@ -68,12 +68,9 @@ if !LINUX_2_4
                default y if powerpc64
                default y if TARGET_coldfire
 
-       config GCC_VERSION_4_3_4
-               default y if TARGET_gemini
-
        config GCC_VERSION_4_3_3_CS
                default y if (mips || mipsel) && !(TARGET_octeon || TARGET_sibyte)
-               default y if (arm || armeb) && !TARGET_gemini
+               default y if (arm || armeb)
 
        config GCC_VERSION_4_4_1
                default y if ubicom32
diff --git a/toolchain/uClibc/config-0.9.30+nptl/arm.gemini b/toolchain/uClibc/config-0.9.30+nptl/arm.gemini
deleted file mode 100644 (file)
index 8043cf6..0000000
+++ /dev/null
@@ -1,26 +0,0 @@
-ARCH_ANY_ENDIAN=y
-ARCH_LITTLE_ENDIAN=y
-ARCH_WANTS_LITTLE_ENDIAN=y
-# CONFIG_ARM10T is not set
-# CONFIG_ARM1136JF_S is not set
-# CONFIG_ARM1176JZF_S is not set
-# CONFIG_ARM1176JZ_S is not set
-# CONFIG_ARM610 is not set
-# CONFIG_ARM710 is not set
-# CONFIG_ARM720T is not set
-# CONFIG_ARM7TDMI is not set
-CONFIG_ARM920T=y
-# CONFIG_ARM922T is not set
-# CONFIG_ARM926T is not set
-# CONFIG_ARM_CORTEX_M1 is not set
-# CONFIG_ARM_CORTEX_M3 is not set
-# CONFIG_ARM_EABI is not set
-# CONFIG_ARM_IWMMXT is not set
-CONFIG_ARM_OABI=y
-# CONFIG_ARM_SA110 is not set
-# CONFIG_ARM_SA1100 is not set
-# CONFIG_ARM_XSCALE is not set
-# CONFIG_GENERIC_ARM is not set
-TARGET_ARCH="arm"
-TARGET_arm=y
-# USE_BX is not set
diff --git a/toolchain/uClibc/config-0.9.30.1/arm.gemini b/toolchain/uClibc/config-0.9.30.1/arm.gemini
deleted file mode 100644 (file)
index 8043cf6..0000000
+++ /dev/null
@@ -1,26 +0,0 @@
-ARCH_ANY_ENDIAN=y
-ARCH_LITTLE_ENDIAN=y
-ARCH_WANTS_LITTLE_ENDIAN=y
-# CONFIG_ARM10T is not set
-# CONFIG_ARM1136JF_S is not set
-# CONFIG_ARM1176JZF_S is not set
-# CONFIG_ARM1176JZ_S is not set
-# CONFIG_ARM610 is not set
-# CONFIG_ARM710 is not set
-# CONFIG_ARM720T is not set
-# CONFIG_ARM7TDMI is not set
-CONFIG_ARM920T=y
-# CONFIG_ARM922T is not set
-# CONFIG_ARM926T is not set
-# CONFIG_ARM_CORTEX_M1 is not set
-# CONFIG_ARM_CORTEX_M3 is not set
-# CONFIG_ARM_EABI is not set
-# CONFIG_ARM_IWMMXT is not set
-CONFIG_ARM_OABI=y
-# CONFIG_ARM_SA110 is not set
-# CONFIG_ARM_SA1100 is not set
-# CONFIG_ARM_XSCALE is not set
-# CONFIG_GENERIC_ARM is not set
-TARGET_ARCH="arm"
-TARGET_arm=y
-# USE_BX is not set
diff --git a/toolchain/uClibc/config-0.9.30.2/arm.gemini b/toolchain/uClibc/config-0.9.30.2/arm.gemini
deleted file mode 100644 (file)
index 8043cf6..0000000
+++ /dev/null
@@ -1,26 +0,0 @@
-ARCH_ANY_ENDIAN=y
-ARCH_LITTLE_ENDIAN=y
-ARCH_WANTS_LITTLE_ENDIAN=y
-# CONFIG_ARM10T is not set
-# CONFIG_ARM1136JF_S is not set
-# CONFIG_ARM1176JZF_S is not set
-# CONFIG_ARM1176JZ_S is not set
-# CONFIG_ARM610 is not set
-# CONFIG_ARM710 is not set
-# CONFIG_ARM720T is not set
-# CONFIG_ARM7TDMI is not set
-CONFIG_ARM920T=y
-# CONFIG_ARM922T is not set
-# CONFIG_ARM926T is not set
-# CONFIG_ARM_CORTEX_M1 is not set
-# CONFIG_ARM_CORTEX_M3 is not set
-# CONFIG_ARM_EABI is not set
-# CONFIG_ARM_IWMMXT is not set
-CONFIG_ARM_OABI=y
-# CONFIG_ARM_SA110 is not set
-# CONFIG_ARM_SA1100 is not set
-# CONFIG_ARM_XSCALE is not set
-# CONFIG_GENERIC_ARM is not set
-TARGET_ARCH="arm"
-TARGET_arm=y
-# USE_BX is not set
diff --git a/toolchain/uClibc/config-0.9.30.3/arm.gemini b/toolchain/uClibc/config-0.9.30.3/arm.gemini
deleted file mode 100644 (file)
index 8043cf6..0000000
+++ /dev/null
@@ -1,26 +0,0 @@
-ARCH_ANY_ENDIAN=y
-ARCH_LITTLE_ENDIAN=y
-ARCH_WANTS_LITTLE_ENDIAN=y
-# CONFIG_ARM10T is not set
-# CONFIG_ARM1136JF_S is not set
-# CONFIG_ARM1176JZF_S is not set
-# CONFIG_ARM1176JZ_S is not set
-# CONFIG_ARM610 is not set
-# CONFIG_ARM710 is not set
-# CONFIG_ARM720T is not set
-# CONFIG_ARM7TDMI is not set
-CONFIG_ARM920T=y
-# CONFIG_ARM922T is not set
-# CONFIG_ARM926T is not set
-# CONFIG_ARM_CORTEX_M1 is not set
-# CONFIG_ARM_CORTEX_M3 is not set
-# CONFIG_ARM_EABI is not set
-# CONFIG_ARM_IWMMXT is not set
-CONFIG_ARM_OABI=y
-# CONFIG_ARM_SA110 is not set
-# CONFIG_ARM_SA1100 is not set
-# CONFIG_ARM_XSCALE is not set
-# CONFIG_GENERIC_ARM is not set
-TARGET_ARCH="arm"
-TARGET_arm=y
-# USE_BX is not set