rename the Profile template that the image builder uses to prevent name conflicts...
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 22 Feb 2007 02:27:01 +0000 (02:27 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 22 Feb 2007 02:27:01 +0000 (02:27 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6336 3c298f89-4303-0410-b956-a3cf2f4a3e73

scripts/metadata.pl
target/imagebuilder/files/Makefile

index 7514a171354e1910b445d861a32dd08981e401e0..d27cd8e59d72c0e26a8be5f2b34e204d0107f518 100755 (executable)
@@ -151,7 +151,7 @@ sub gen_target_mk() {
     PACKAGES:=".join(" ", @{$profile->{packages}})."
   endef";
   $profiles_eval .= "
-\$(eval \$(call Profile,$conf\_$profile->{id}))"
+\$(eval \$(call AddProfile,$conf\_$profile->{id}))"
                }
                print "
 ifeq (\$(CONFIG_LINUX_$conf),y)
index eae3697e8130f40b2a113030c959ce229b757481..b36e2f2e31235308813a0ed781b8099a818b8ed5 100644 (file)
@@ -37,7 +37,7 @@ define Profile/Default
   PACKAGES:=
 endef
 
-define Profile
+define AddProfile
   $(eval $(call Profile/Default))
   $(eval $(call Profile/$(1)))
   ifneq ($(ID),)