add tgz image (kernel+rootfs tar archive) for testing
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 25 Jul 2005 15:38:45 +0000 (15:38 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 25 Jul 2005 15:38:45 +0000 (15:38 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@1563 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/Config.in
target/linux/image/tgz.mk [new file with mode: 0644]

index 5019b3d7223fe3d0c74e450eb7c404d2d3937a1a..63d87aee3f48aa900a0df76dd6cdb58ae5514152 100644 (file)
@@ -3,15 +3,23 @@ menu "Target Root Filesystem"
        config BR2_TARGET_ROOTFS_JFFS2
                bool "jffs2"
                default y
+               depends BR2_mipsel
                help
                  Build a jffs2 root filesystem
 
        config BR2_TARGET_ROOTFS_SQUASHFS_LZMA
                bool "squashfs-lzma"
                default y
+               depends BR2_mipsel
                help
                  Build a squashfs-lzma root filesystem
 
+       config BR2_TARGET_ROOTFS_TGZ
+               bool "tgz"
+               default y
+               help
+                 Build a compressed tar archive of the kernel and the root filesystem
+
 endmenu
 
 menu "Kernel Configuration / Device Support"
diff --git a/target/linux/image/tgz.mk b/target/linux/image/tgz.mk
new file mode 100644 (file)
index 0000000..850f5a6
--- /dev/null
@@ -0,0 +1,14 @@
+$(KDIR)/vmlinux.gz: $(KDIR)/vmlinux
+       gzip -c -vf9 < $< > $@
+
+$(KDIR)/rootfs.tar.gz: $(KDIR)/vmlinux.gz
+       tar -cf $(KDIR)/rootfs.tar --owner=root --group=root -C $(KDIR)/ ./vmlinux.gz
+       tar -rf $(KDIR)/rootfs.tar --owner=root --group=root -C $(KDIR)/root/ .
+       gzip -f9 $(KDIR)/rootfs.tar
+
+tgz-install: $(KDIR)/rootfs.tar.gz
+       $(MAKE) -C $(BOARD) install KERNEL="$(KERNEL)" FS="tgz"
+
+prepare:
+compile:
+install: tgz-install