fix overzealous kmod stripping - it killed kernel module parameters (#1301)
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 6 Feb 2007 00:56:36 +0000 (00:56 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 6 Feb 2007 00:56:36 +0000 (00:56 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6271 3c298f89-4303-0410-b956-a3cf2f4a3e73

rules.mk

index 42e997859173c1d3c826d05c169755b0fed69ce9..b63fcf31c8f5f7a6934473e64992f4188263599c 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -88,7 +88,7 @@ TARGET_CONFIGURE_OPTS:= \
 # strip an entire directory
 RSTRIP:= \
   STRIP="$(STRIP)" \
-  STRIP_KMOD="$(TARGET_CROSS)strip --strip-unneeded --remove-section=.comment" \
+  STRIP_KMOD="$(TARGET_CROSS)strip --strip-unneeded --remove-section=.comment -w -K '__mod*'" \
   $(SCRIPT_DIR)/rstrip.sh
 
 # where to build (and put) .ipk packages