hostapd: select crda if mac80211 is selected
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 16 Feb 2010 18:29:03 +0000 (18:29 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 16 Feb 2010 18:29:03 +0000 (18:29 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@19667 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/hostapd/Makefile

index b68b5f9c5767b429e4577df361108653494f06f8..e6e23138645656562d0c95be73f2cd29c3782420 100644 (file)
@@ -75,7 +75,7 @@ define Package/hostapd/Default
   CATEGORY:=Network
   TITLE:=IEEE 802.1x Authenticator
   URL:=http://hostap.epitest.fi/
-  DEPENDS:=@!TARGET_avr32 @!TARGET_etrax +PACKAGE_kmod-mac80211:libnl-tiny
+  DEPENDS:=@!TARGET_avr32 @!TARGET_etrax +PACKAGE_kmod-mac80211:libnl-tiny +PACKAGE_kmod-mac80211:crda
   MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
 endef
 
@@ -116,7 +116,7 @@ define Package/wpad/Default
   CATEGORY:=Network
   TITLE:=IEEE 802.1x Authenticator/Supplicant
   URL:=http://hostap.epitest.fi/
-  DEPENDS:=@!TARGET_avr32 @!TARGET_etrax +PACKAGE_kmod-mac80211:libnl-tiny
+  DEPENDS:=@!TARGET_avr32 @!TARGET_etrax +PACKAGE_kmod-mac80211:libnl-tiny +PACKAGE_kmod-mac80211:crda
   MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
 endef
 
@@ -146,7 +146,7 @@ define Package/wpa-supplicant
   CATEGORY:=Network
   TITLE:=WPA Supplicant
   URL:=http://hostap.epitest.fi/wpa_supplicant/
-  DEPENDS:=@!TARGET_avr32 @!TARGET_etrax +PACKAGE_kmod-mac80211:libnl-tiny
+  DEPENDS:=@!TARGET_avr32 @!TARGET_etrax +PACKAGE_kmod-mac80211:libnl-tiny +PACKAGE_kmod-mac80211:crda
   VARIANT:=supplicant-full
   MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
 endef