[backfire] merge r22397
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 8 Aug 2010 23:34:49 +0000 (23:34 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 8 Aug 2010 23:34:49 +0000 (23:34 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/backfire@22551 3c298f89-4303-0410-b956-a3cf2f4a3e73

tools/quilt/Makefile
tools/quilt/patches/100-patch_2.6.1_version.patch [new file with mode: 0644]

index a6f2a9e95fd5bc8fb099599ed3e029f9964311f4..a57d8844f94fe851c745832394359eed969e40bf 100644 (file)
@@ -16,6 +16,7 @@ PKG_MD5SUM:=d33d2442bd34387260b1c1db3e623af0
 include $(INCLUDE_DIR)/host-build.mk
 
 define Host/Configure
+       cd $(HOST_BUILD_DIR) && autoconf
        $(call Host/Configure/Default)
        [ -f $(HOST_BUILD_DIR)/Makefile ]
 endef
diff --git a/tools/quilt/patches/100-patch_2.6.1_version.patch b/tools/quilt/patches/100-patch_2.6.1_version.patch
new file mode 100644 (file)
index 0000000..84f2753
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -274,7 +274,7 @@ fi
+ AC_MSG_CHECKING([the version of $PATCH])
+ if $PATCH --version 2> /dev/null | grep GNU >/dev/null; then
+   set -- `$PATCH --version 2> /dev/null`
+-  patch_version=$2
++  test $2 == "patch" && patch_version=$3 || patch_version=$2
+   AC_MSG_RESULT($patch_version)
+   saved_IFS=$IFS; IFS='.'
+   set -- $patch_version