final fix for the profile selection
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 2 Mar 2007 23:36:59 +0000 (23:36 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 2 Mar 2007 23:36:59 +0000 (23:36 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6474 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/target.mk

index d0f7b9bc2b597c395caa95e1fcc237c90ffb96e2..1718a869c14780853bc61c69f9d66cf4769d87b7 100644 (file)
@@ -5,14 +5,16 @@
 # See /LICENSE for more information.
 #
 
-include $(TMP_DIR)/.target.mk
 
 define AddProfile
-  ifeq ($(CONFIG_LINUX_$(call confname,$(KERNEL)_$(1))),y)
-    PROFILE=$(1)
+  ifeq ($(CONFIG_LINUX_$(1)),y)
+    $(call Profile/$(1))
+    PROFILE=$$(ID)
   endif
 endef
 
+include $(TMP_DIR)/.target.mk
+
 ifeq ($(IB),1)
 $(TMP_DIR)/.target.mk: $(TOPDIR)/.target.mk
        $(CP) $< $@