[backfire] merge r21820 and r21821
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 16 Jun 2010 20:28:55 +0000 (20:28 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 16 Jun 2010 20:28:55 +0000 (20:28 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/backfire@21822 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/hostapd/Makefile
package/hostapd/files/wpa_supplicant.sh

index 72a7205dd162d2d37feadb28de92515d67d0523e..948e1339b8fc4ba6333ebf69ca28a2768986b8d0 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2009 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=hostapd
 PKG_VERSION:=20100418
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 PKG_REV:=0b86f67a2970403d1b1b6d34ce49f5485ef5dbb3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
index 74d20c66623655fca813e69389c6a2a868bc771b..28d5d20565f3c74b790832e95aadefa0c172a6c1 100644 (file)
@@ -70,6 +70,7 @@ wpa_supplicant_setup_vif() {
                        key_mgmt='WPA-EAP'
                        config_get ieee80211w "$vif" ieee80211w
                        config_get ca_cert "$vif" ca_cert
+                       config_get eap_type "$vif" eap_type
                        ca_cert=${ca_cert:+"ca_cert=\"$ca_cert\""}
                        case "$eap_type" in
                                tls)