add -mlong-calls cflag to alsa mips build (patch from #1391)
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 23 Feb 2007 14:50:15 +0000 (14:50 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 23 Feb 2007 14:50:15 +0000 (14:50 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6349 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/alsa/Makefile

index a814da5109799dae7ed1e7e43bc4fc2aca3d40b7..8aa80e74a5c75f6781ed094eeae68ca2e466562e 100644 (file)
@@ -36,7 +36,7 @@ ifeq ($(KERNEL),2.4)
     KERNEL_C_OPTS:= -Os -mpreferred-stack-boundary=2 -march=i486 -fno-unit-at-a-time
   endif
   ifeq ($(LINUX_KARCH),mips)
-    KERNEL_C_OPTS:= -Os -G 0 -mno-abicalls -fno-pic -finline-limit=100000 -mabi=32 -march=mips32 -Wa,-32 -Wa,-march=mips32 -Wa,-mips32 -Wa,--trap
+    KERNEL_C_OPTS:= -Os -G 0 -mlong-calls -mno-abicalls -fno-pic -finline-limit=100000 -mabi=32 -march=mips32 -Wa,-32 -Wa,-march=mips32 -Wa,-mips32 -Wa,--trap
   endif
 endif
 ifeq ($(LINUX_KARCH),i386)