standardize Makefile, change section from base to net
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 23 Sep 2006 13:29:15 +0000 (13:29 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 23 Sep 2006 13:29:15 +0000 (13:29 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@4814 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/pptp/Makefile

index b060c12a793b90ef46cf4b9c84f61cdb2928d4bb..b32ab0627580bd2651adc1414ff81daafc8852b8 100644 (file)
@@ -21,20 +21,21 @@ PKG_CAT:=zcat
 include $(INCLUDE_DIR)/package.mk
 
 define Package/pptp
-SECTION:=base
-# CATEGORY:=FIXME
-TITLE:=PPTP (Point-to-Point Tunneling Protocol) client
-DESCRIPTION:=A Point-to-Point Tunneling Protocol Client
-URL:=http://pptpclient.sourceforge.net/
+  SECTION:=net
+  CATEGORY:=Network
+  TITLE:=PPTP client
+  DESCRIPTION:=\
+       This package contains a PPTP (Point-to-Point Tunneling Protocol) client.
+  URL:=http://pptpclient.sourceforge.net/
 endef
 
 define Package/pptp/install
+       install -d -m0755 $(1)/usr/sbin
+       install -m0755 $(PKG_BUILD_DIR)/pptp $(1)/usr/sbin/
        install -d -m0755 $(1)/etc/ppp
        install -m0644 ./files/options.pptp $(1)/etc/ppp/
        install -d -m0755 $(1)/lib/network
        install -m0755 ./files/pptp.sh $(1)/lib/network/
-       install -d -m0755 $(1)/usr/sbin
-       install -m0755 $(PKG_BUILD_DIR)/pptp $(1)/usr/sbin/
 endef
 
 $(eval $(call BuildPackage,pptp))