fix CONFIG_ALL
authormbm <mbm@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 2 Aug 2006 13:40:11 +0000 (13:40 +0000)
committermbm <mbm@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 2 Aug 2006 13:40:11 +0000 (13:40 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@4397 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/package.mk

index 3dc944dbfa0a21774866fd1e0027c91f5ae7d18f..fbd4cf714957f524355e6a022b3d951a433a6b56 100644 (file)
@@ -19,7 +19,7 @@ define Build/DefaultTargets
         $(PKG_BUILD_DIR)/.prepared: package-clean
       endif
 
         $(PKG_BUILD_DIR)/.prepared: package-clean
       endif
 
-      ifneq ($$(shell $(SCRIPT_DIR)/timestamp.pl -p -x ipkg $(IPKG_$(1)) $(PKG_BUILD_DIR)),$(IPKG_$(1)))
+      ifneq ($$(shell $(SCRIPT_DIR)/timestamp.pl -p -x ipkg -x ipkg-install $(IPKG_$(1)) $(PKG_BUILD_DIR) | tee /tmp/check_$(1)),$(IPKG_$(1)))
         $(PKG_BUILD_DIR)/.built: package-rebuild
       endif
     endif
         $(PKG_BUILD_DIR)/.built: package-rebuild
       endif
     endif
@@ -121,7 +121,7 @@ define BuildPackage
       install-targets: $$(INFO_$(1))
     endif
 
       install-targets: $$(INFO_$(1))
     endif
 
-    ifneq ($(CONFIG_PACKAGE_$(1))$(DEVELOPER),)
+    ifneq ($(CONFIG_PACKAGE_$(1))$(CONFIG_ALL),)
       compile-targets: $$(IPKG_$(1))
     endif
   endif
       compile-targets: $$(IPKG_$(1))
     endif
   endif