update lighttpd to new upstream release (v1.4.8),
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 6 Dec 2005 11:52:18 +0000 (11:52 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 6 Dec 2005 11:52:18 +0000 (11:52 +0000)
add a mod-accesslog sub-package.

git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@2581 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/lighttpd/Config.in
package/lighttpd/Makefile
package/lighttpd/ipkg/lighttpd-mod-accesslog.control [new file with mode: 0644]

index 997036c57a13da63db4871629fe9d11f1315ccb8..cf9dedf3959661b3ba923853beb4eb79d59add53 100644 (file)
@@ -13,6 +13,12 @@ config BR2_PACKAGE_LIGHTTPD
          
          Depends: libopenssl, libpcre
 
+config BR2_PACKAGE_LIGHTTPD_MOD_ACCESSLOG
+       prompt   "lighttpd-mod-accesslog.......... Access logging module"
+       tristate 
+       default m if CONFIG_DEVEL
+       depends BR2_PACKAGE_LIGHTTPD
+
 config BR2_PACKAGE_LIGHTTPD_MOD_ALIAS
        prompt   "lighttpd-mod-alias.............. Directory alias module"
        tristate 
index 486f851b3572c03494102f4df78ca6d2f143c6f5..65a8d35141bcbb5727e4289f5144d44681748757 100644 (file)
@@ -3,9 +3,9 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=lighttpd
-PKG_VERSION:=1.4.7
+PKG_VERSION:=1.4.8
 PKG_RELEASE:=1
-PKG_MD5SUM:=4d1b02e2008e5f35e4df7defee186fdd
+PKG_MD5SUM:=7d7790ef95ff5755f73bfcda4f13696d
 
 PKG_SOURCE_URL:=http://www.lighttpd.net/download/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
@@ -27,6 +27,7 @@ $$(IPKG_$(1)):
 endef
 
 $(eval $(call PKG_template,LIGHTTPD,lighttpd,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+$(eval $(call PKG_template,LIGHTTPD_MOD_ACCESSLOG,lighttpd-mod-accesslog,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_template,LIGHTTPD_MOD_ALIAS,lighttpd-mod-alias,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_template,LIGHTTPD_MOD_AUTH,lighttpd-mod-auth,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_template,LIGHTTPD_MOD_CGI,lighttpd-mod-cgi,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
@@ -41,6 +42,7 @@ $(eval $(call PKG_template,LIGHTTPD_MOD_SSI,lighttpd-mod-ssi,$(PKG_VERSION)-$(PK
 $(eval $(call PKG_template,LIGHTTPD_MOD_STATUS,lighttpd-mod-status,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_template,LIGHTTPD_MOD_USERTRACK,lighttpd-mod-usertrack,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 
+$(eval $(call PKG_mod_template,LIGHTTPD_MOD_ACCESSLOG,accesslog))
 $(eval $(call PKG_mod_template,LIGHTTPD_MOD_ALIAS,alias))
 $(eval $(call PKG_mod_template,LIGHTTPD_MOD_AUTH,auth))
 $(eval $(call PKG_mod_template,LIGHTTPD_MOD_CGI,cgi))
diff --git a/package/lighttpd/ipkg/lighttpd-mod-accesslog.control b/package/lighttpd/ipkg/lighttpd-mod-accesslog.control
new file mode 100644 (file)
index 0000000..6401226
--- /dev/null
@@ -0,0 +1,5 @@
+Package: lighttpd-mod-accesslog
+Priority: optional
+Section: net
+Description: an access logging module for lighttpd
+Depends: lighttpd