add a fix for mtd build with host gcc 4
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 2 Jul 2005 08:08:56 +0000 (08:08 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 2 Jul 2005 08:08:56 +0000 (08:08 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@1315 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/image/jffs2/Makefile
target/linux/image/jffs2/patches/gcc4-fix.patch [new file with mode: 0644]

index 8734ee22517f6fb503534415e24560ad396153a5..d5f03bef4add669adaed8bb4df855228cf292752 100644 (file)
@@ -11,6 +11,7 @@ $(DL_DIR)/$(MTD_SOURCE):
 
 $(MTD_DIR)/.unpacked: $(DL_DIR)/$(MTD_SOURCE)
        zcat $(DL_DIR)/$(MTD_SOURCE) | tar -C $(BUILD_DIR) -xvf -
+       $(PATCH) $(MTD_DIR) ./patches
        touch $(MTD_DIR)/.unpacked
 
 $(MTD_DIR)/util/mkfs.jffs2: $(MTD_DIR)/.unpacked
diff --git a/target/linux/image/jffs2/patches/gcc4-fix.patch b/target/linux/image/jffs2/patches/gcc4-fix.patch
new file mode 100644 (file)
index 0000000..c7a274d
--- /dev/null
@@ -0,0 +1,12 @@
+diff -urN mtd-20050122.orig.old/include/mtd/jffs2-user.h mtd-20050122.orig.dev/include/mtd/jffs2-user.h
+--- mtd-20050122.orig.old/include/mtd/jffs2-user.h     2004-05-05 13:57:54.000000000 +0200
++++ mtd-20050122.orig.dev/include/mtd/jffs2-user.h     2005-07-02 10:03:09.000000000 +0200
+@@ -19,8 +19,6 @@
+ #undef je32_to_cpu
+ #undef jemode_to_cpu
+-extern int target_endian;
+-
+ #define t16(x) ({ uint16_t __b = (x); (target_endian==__BYTE_ORDER)?__b:bswap_16(__b); })
+ #define t32(x) ({ uint32_t __b = (x); (target_endian==__BYTE_ORDER)?__b:bswap_32(__b); })