add checks for the kernel config when building hostap for linux 2.6
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 4 Sep 2006 21:28:28 +0000 (21:28 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 4 Sep 2006 21:28:28 +0000 (21:28 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@4751 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/hostap/Makefile

index b653b14550293eebaf714118f5f3467f94664048..90281fe6b592682352663d2d2cde209ffa541e16 100644 (file)
@@ -96,20 +96,25 @@ ifeq ($(KERNEL),2.6)
   define Build/Compile
   endef
   
   define Build/Compile
   endef
   
+ifeq ($(CONFIG_HOSTAP),m)
   define Package/kmod-hostap/install
        install -m0755 -d $(1)/lib/modules/$(LINUX_VERSION)
        $(CP) \
                $(MODULES_DIR)/kernel/drivers/net/wireless/hostap/hostap.$(LINUX_KMOD_SUFFIX) \
                $(1)/lib/modules/$(LINUX_VERSION)/
   endef
   define Package/kmod-hostap/install
        install -m0755 -d $(1)/lib/modules/$(LINUX_VERSION)
        $(CP) \
                $(MODULES_DIR)/kernel/drivers/net/wireless/hostap/hostap.$(LINUX_KMOD_SUFFIX) \
                $(1)/lib/modules/$(LINUX_VERSION)/
   endef
+endif
 
 
+ifeq ($(CONFIG_HOSTAP_PCI),m)
   define Package/kmod-hostap-pci/install
        install -m0755 -d $(1)/lib/modules/$(LINUX_VERSION)
        $(CP) \
                $(MODULES_DIR)/kernel/drivers/net/wireless/hostap/hostap_pci.$(LINUX_KMOD_SUFFIX) \
                $(1)/lib/modules/$(LINUX_VERSION)/
   endef
   define Package/kmod-hostap-pci/install
        install -m0755 -d $(1)/lib/modules/$(LINUX_VERSION)
        $(CP) \
                $(MODULES_DIR)/kernel/drivers/net/wireless/hostap/hostap_pci.$(LINUX_KMOD_SUFFIX) \
                $(1)/lib/modules/$(LINUX_VERSION)/
   endef
+endif
 
 
+ifeq ($(CONFIG_HOSTAP_PLX),m)
   define Package/kmod-hostap-plx/install
        install -m0755 -d $(1)/lib/modules/$(LINUX_VERSION)
        $(CP) \
   define Package/kmod-hostap-plx/install
        install -m0755 -d $(1)/lib/modules/$(LINUX_VERSION)
        $(CP) \
@@ -117,6 +122,7 @@ ifeq ($(KERNEL),2.6)
                $(1)/lib/modules/$(LINUX_VERSION)/
   endef
 endif
                $(1)/lib/modules/$(LINUX_VERSION)/
   endef
 endif
+endif
 
 $(eval $(call BuildPackage,kmod-hostap))
 $(eval $(call BuildPackage,kmod-hostap-pci))
 
 $(eval $(call BuildPackage,kmod-hostap))
 $(eval $(call BuildPackage,kmod-hostap-pci))