hostapd: fix wpad compile error by preventing make spam from showing up in the cflags...
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 23 Jan 2010 18:25:04 +0000 (18:25 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 23 Jan 2010 18:25:04 +0000 (18:25 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@19295 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/hostapd/Makefile

index 93392110ab1ce117aa2b9a0c19349957105d665f..3aec903728c198a2bcdc645bd3465afa538d5b99 100644 (file)
@@ -218,8 +218,8 @@ endef
 
 define Build/Compile/wpad
        echo ` \
 
 define Build/Compile/wpad
        echo ` \
-               $(call Build/RunMake,hostapd,MULTICALL=1 dump_cflags); \
-               $(call Build/RunMake,wpa_supplicant,dump_cflags) | sed -e 's,$(TARGET_CFLAGS),,' \
+               $(call Build/RunMake,hostapd,-s MULTICALL=1 dump_cflags); \
+               $(call Build/RunMake,wpa_supplicant,-s dump_cflags) | sed -e 's,$(TARGET_CFLAGS),,' \
        ` > $(PKG_BUILD_DIR)/.cflags
        $(call Build/RunMake,hostapd, \
                CFLAGS="$$$$(cat $(PKG_BUILD_DIR)/.cflags)" \
        ` > $(PKG_BUILD_DIR)/.cflags
        $(call Build/RunMake,hostapd, \
                CFLAGS="$$$$(cat $(PKG_BUILD_DIR)/.cflags)" \