backport xz from r24481
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 11 Dec 2010 13:23:09 +0000 (13:23 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 11 Dec 2010 13:23:09 +0000 (13:23 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/backfire@24482 3c298f89-4303-0410-b956-a3cf2f4a3e73

tools/Makefile
tools/xz/Makefile [new file with mode: 0644]

index 83a50bcda3b7f4bc5f0d5c3c0ffd29fabd753369..5c33202e2cbf5bc6011904c6542f2d03c4c29887 100644 (file)
@@ -15,7 +15,7 @@ tools-$(CONFIG_GCC_VERSION_4_3)$(CONFIG_GCC_VERSION_4_4) += gmp mpfr
 endif
 tools-y += m4 autoconf automake bison pkg-config sed mklibs
 tools-y += sstrip ipkg-utils genext2fs libuuid mtd-utils mkimage
 endif
 tools-y += m4 autoconf automake bison pkg-config sed mklibs
 tools-y += sstrip ipkg-utils genext2fs libuuid mtd-utils mkimage
-tools-y += firmware-utils patch-cmdline quilt yaffs2
+tools-y += firmware-utils patch-cmdline quilt yaffs2 xz
 tools-$(CONFIG_TARGET_orion) += wrt350nv2-builder upslug2
 tools-$(CONFIG_TARGET_x86) += qemu
 ifneq ($(CONFIG_LINUX_2_4)$(CONFIG_LINUX_2_6_25),)
 tools-$(CONFIG_TARGET_orion) += wrt350nv2-builder upslug2
 tools-$(CONFIG_TARGET_x86) += qemu
 ifneq ($(CONFIG_LINUX_2_4)$(CONFIG_LINUX_2_6_25),)
diff --git a/tools/xz/Makefile b/tools/xz/Makefile
new file mode 100644 (file)
index 0000000..5689e18
--- /dev/null
@@ -0,0 +1,18 @@
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=xz
+PKG_VERSION:=5.0.0
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=http://tukaani.org/xz
+PKG_MD5SUM:=0652c09fdbb93ae2ce78c1368ffda612
+
+include $(INCLUDE_DIR)/host-build.mk
+
+$(eval $(call HostBuild))