Port arptables to -ng
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 30 Jul 2006 17:53:04 +0000 (17:53 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 30 Jul 2006 17:53:04 +0000 (17:53 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@4340 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/arptables/Config.in [new file with mode: 0644]
package/arptables/Makefile [new file with mode: 0644]
package/arptables/ipkg/arptables.control [new file with mode: 0644]

diff --git a/package/arptables/Config.in b/package/arptables/Config.in
new file mode 100644 (file)
index 0000000..6583d32
--- /dev/null
@@ -0,0 +1,9 @@
+config BR2_PACKAGE_ARPTABLES
+       prompt "arptables......................... ARP firewall administration utility"
+       tristate
+       default m if CONFIG_DEVEL
+       help
+         ARP Firewalling (arptables)
+         
+         http://ebtables.sourceforge.net/
+
diff --git a/package/arptables/Makefile b/package/arptables/Makefile
new file mode 100644 (file)
index 0000000..b4bfe18
--- /dev/null
@@ -0,0 +1,46 @@
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=arptables
+PKG_VERSION:=0.0.3
+PKG_RELEASE:=1
+PKG_MD5SUM:=1672244603c8979577aa4738be35a759
+
+PKG_SOURCE_URL:=@SF/ebtables
+PKG_SOURCE:=$(PKG_NAME)-v$(PKG_VERSION).tar.gz
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-v$(PKG_VERSION)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/arptables
+  SECTION:=net
+  CATEGORY:=Network
+  TITLE:=ARP firewalling software
+  DESCRIPTION:=ARP firewalling software
+  URL:=http://ebtables.sourceforge.net
+endef
+
+define Build/Compile
+       rm -rf $(PKG_INSTALL_DIR)
+       mkdir -p $(PKG_INSTALL_DIR)
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               CC=$(TARGET_CC) LD=$(TARGET_CROSS)ld \
+               COPT_FLAGS="$(TARGET_CFLAGS)" \
+               KERNEL_DIR="./include/linux"
+endef
+
+define Package/arptables/install
+       install -m0755 -d $(1)/usr/sbin
+       $(CP) $(PKG_BUILD_DIR)/$(PKG_NAME) $(1)/usr/sbin/
+endef
+
+$(eval $(call BuildPackage,arptables))
diff --git a/package/arptables/ipkg/arptables.control b/package/arptables/ipkg/arptables.control
new file mode 100644 (file)
index 0000000..3fec57b
--- /dev/null
@@ -0,0 +1,4 @@
+Package: arptables
+Priority: optional
+Section: net
+Description: ARP firewalling software