[kernel] netfilter: remove CHAOS, TARPIT and DELUDE references
authorjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 9 Feb 2009 13:27:39 +0000 (13:27 +0000)
committerjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 9 Feb 2009 13:27:39 +0000 (13:27 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14461 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/netfilter.mk
package/iptables/Makefile
package/kernel/modules/netfilter.mk

index 6968feffd3fa85059fc70adafa2a670828e1a46a..f474b6a398131263e66809990c90c64eefedf793 100644 (file)
@@ -84,13 +84,9 @@ $(eval $(call nf_add,IPT_EXTRA,CONFIG_IP_NF_MATCH_OWNER, $(P_V4)ipt_owner))
 $(eval $(call nf_add,IPT_EXTRA,CONFIG_NETFILTER_XT_MATCH_PHYSDEV, $(P_XT)xt_physdev))
 $(eval $(call nf_add,IPT_EXTRA,CONFIG_IP_NF_MATCH_PKTTYPE, $(P_V4)ipt_pkttype))
 $(eval $(call nf_add,IPT_EXTRA,CONFIG_NETFILTER_XT_MATCH_PKTTYPE, $(P_XT)xt_pkttype))
-$(eval $(call nf_add,IPT_EXTRA,CONFIG_NETFILTER_XT_MATCH_PORTSCAN, $(P_XT)xt_portscan))
 #$(eval $(call nf_add,IPT_EXTRA,CONFIG_IP_NF_MATCH_QUOTA, $(P_V4)ipt_quota))
 $(eval $(call nf_add,IPT_EXTRA,CONFIG_NETFILTER_XT_MATCH_QUOTA, $(P_XT)xt_quota))
 
-$(eval $(call nf_add,IPT_EXTRA,CONFIG_NETFILTER_XT_TARGET_TARPIT, $(P_XT)xt_TARPIT))
-$(eval $(call nf_add,IPT_EXTRA,CONFIG_NETFILTER_XT_TARGET_DELUDE, $(P_XT)xt_DELUDE))
-$(eval $(call nf_add,IPT_EXTRA,CONFIG_NETFILTER_XT_TARGET_CHAOS, $(P_XT)xt_CHAOS))
 #$(eval $(call nf_add,IPT_EXTRA,CONFIG_IP_NF_TARGET_ROUTE, $(P_V4)ipt_ROUTE))
 
 
index 58b4d722d517296d9bbbc1087c74e2c2fef26404..1074f582ccc75ec735c563f43d83bdadb157e2fa 100644 (file)
@@ -211,9 +211,6 @@ define Package/iptables-mod-extra/description
  - libipt_recent
  - iptable_raw
  - libipt_NOTRACK
- - libipt_TARPIT
- - libipt_DELUDE
- - libipt_CHAOS
 endef
 
 define Package/iptables-mod-ipset
index c17c8a8def3116c673ef0e7f61af1d8565607917..3cb00d68558508cfde2cdd45318ff56843b4d58f 100644 (file)
@@ -347,9 +347,6 @@ define KernelPackage/ipt-extra/description
  - ipt_recent
  - iptable_raw
  - xt_NOTRACK
- - xt_TARPIT
- - xt_DELUDE
- - xt_CHAOS
 endef
 
 $(eval $(call KernelPackage,ipt-extra))