[backfire] package: sync opkg with trunk
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 26 Feb 2011 20:16:40 +0000 (20:16 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 26 Feb 2011 20:16:40 +0000 (20:16 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/backfire@25743 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/opkg/Makefile
package/opkg/files/opkg.conf
package/opkg/patches/001-ship-pkg-m4.patch [new file with mode: 0644]
package/opkg/patches/002-no-shave.patch [new file with mode: 0644]
package/opkg/patches/009-remove-upgrade-all.patch [new file with mode: 0644]
package/opkg/patches/014-errors-to-stderr.patch [new file with mode: 0644]

index 2870abdc038af1cef9b5f9aa0662b91d3f7c41c7..25cdc524c6d999527b7043bfc51b8d8b9f45a959 100644 (file)
@@ -18,6 +18,7 @@ PKG_SOURCE_SUBDIR:=opkg-$(PKG_VERSION)
 PKG_SOURCE_URL:=http://opkg.googlecode.com/svn/trunk/
 PKG_SOURCE:=$(PKG_SOURCE_SUBDIR).tar.gz
 PKG_FIXUP = libtool
 PKG_SOURCE_URL:=http://opkg.googlecode.com/svn/trunk/
 PKG_SOURCE:=$(PKG_SOURCE_SUBDIR).tar.gz
 PKG_FIXUP = libtool
+PKG_REMOVE_FILES = autogen.sh aclocal.m4
 
 include $(INCLUDE_DIR)/package.mk
 include $(INCLUDE_DIR)/host-build.mk
 
 include $(INCLUDE_DIR)/package.mk
 include $(INCLUDE_DIR)/host-build.mk
@@ -53,13 +54,6 @@ CONFIGURE_ARGS += \
        --with-opkgetcdir=/etc \
        --with-opkglockfile=/var/lock/opkg.lock
 
        --with-opkgetcdir=/etc \
        --with-opkglockfile=/var/lock/opkg.lock
 
-define Build/Configure
-       (cd $(PKG_BUILD_DIR); \
-               autoreconf -v --install || exit 1 \
-       );
-       $(call Build/Configure/Default)
-endef
-
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                CC="$(TARGET_CC)" \
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                CC="$(TARGET_CC)" \
@@ -83,19 +77,12 @@ define Build/InstallDev
 endef
 
 
 endef
 
 
-HOST_BUILD_DEPENDS:=libtool/host
-
 HOST_CONFIGURE_ARGS+= \
        --disable-curl \
        --disable-gpg \
        --with-opkgetcdir=/etc \
        --with-opkglockfile=/tmp/opkg.lock
 
 HOST_CONFIGURE_ARGS+= \
        --disable-curl \
        --disable-gpg \
        --with-opkgetcdir=/etc \
        --with-opkglockfile=/tmp/opkg.lock
 
-define Host/Configure
-       (cd $(HOST_BUILD_DIR); autoreconf -v --install || exit 1)
-       $(call Host/Configure/Default)
-endef
-
 define Host/Compile
        $(MAKE) -C $(HOST_BUILD_DIR) CC="$(HOSTCC)" all
 endef
 define Host/Compile
        $(MAKE) -C $(HOST_BUILD_DIR) CC="$(HOSTCC)" all
 endef
index d99c80df8ca862d94886cb389804d1ba35b321f1..0e85936ba2c9a216a1f1231125446115c82d0bb9 100644 (file)
@@ -1,4 +1,4 @@
-src/gz packages http://downloads.openwrt.org/backfire/10.03/$S/packages
+src/gz snapshots http://downloads.openwrt.org/snapshots/trunk/$S/packages
 dest root /
 dest ram /tmp
 lists_dir ext /var/opkg-lists
 dest root /
 dest ram /tmp
 lists_dir ext /var/opkg-lists
diff --git a/package/opkg/patches/001-ship-pkg-m4.patch b/package/opkg/patches/001-ship-pkg-m4.patch
new file mode 100644 (file)
index 0000000..4ca0f88
--- /dev/null
@@ -0,0 +1,168 @@
+--- /dev/null
++++ b/m4/pkg.m4
+@@ -0,0 +1,157 @@
++# pkg.m4 - Macros to locate and utilise pkg-config.            -*- Autoconf -*-
++# 
++# Copyright © 2004 Scott James Remnant <scott@netsplit.com>.
++#
++# This program is free software; you can redistribute it and/or modify
++# it under the terms of the GNU General Public License as published by
++# the Free Software Foundation; either version 2 of the License, or
++# (at your option) any later version.
++#
++# This program is distributed in the hope that it will be useful, but
++# WITHOUT ANY WARRANTY; without even the implied warranty of
++# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
++# General Public License for more details.
++#
++# You should have received a copy of the GNU General Public License
++# along with this program; if not, write to the Free Software
++# Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
++#
++# As a special exception to the GNU General Public License, if you
++# distribute this file as part of a program that contains a
++# configuration script generated by Autoconf, you may include it under
++# the same distribution terms that you use for the rest of that program.
++
++# PKG_PROG_PKG_CONFIG([MIN-VERSION])
++# ----------------------------------
++AC_DEFUN([PKG_PROG_PKG_CONFIG],
++[m4_pattern_forbid([^_?PKG_[A-Z_]+$])
++m4_pattern_allow([^PKG_CONFIG(_PATH)?$])
++AC_ARG_VAR([PKG_CONFIG], [path to pkg-config utility])dnl
++if test "x$ac_cv_env_PKG_CONFIG_set" != "xset"; then
++      AC_PATH_TOOL([PKG_CONFIG], [pkg-config])
++fi
++if test -n "$PKG_CONFIG"; then
++      _pkg_min_version=m4_default([$1], [0.9.0])
++      AC_MSG_CHECKING([pkg-config is at least version $_pkg_min_version])
++      if $PKG_CONFIG --atleast-pkgconfig-version $_pkg_min_version; then
++              AC_MSG_RESULT([yes])
++      else
++              AC_MSG_RESULT([no])
++              PKG_CONFIG=""
++      fi
++              
++fi[]dnl
++])# PKG_PROG_PKG_CONFIG
++
++# PKG_CHECK_EXISTS(MODULES, [ACTION-IF-FOUND], [ACTION-IF-NOT-FOUND])
++#
++# Check to see whether a particular set of modules exists.  Similar
++# to PKG_CHECK_MODULES(), but does not set variables or print errors.
++#
++#
++# Similar to PKG_CHECK_MODULES, make sure that the first instance of
++# this or PKG_CHECK_MODULES is called, or make sure to call
++# PKG_CHECK_EXISTS manually
++# --------------------------------------------------------------
++AC_DEFUN([PKG_CHECK_EXISTS],
++[AC_REQUIRE([PKG_PROG_PKG_CONFIG])dnl
++if test -n "$PKG_CONFIG" && \
++    AC_RUN_LOG([$PKG_CONFIG --exists --print-errors "$1"]); then
++  m4_ifval([$2], [$2], [:])
++m4_ifvaln([$3], [else
++  $3])dnl
++fi])
++
++
++# _PKG_CONFIG([VARIABLE], [COMMAND], [MODULES])
++# ---------------------------------------------
++m4_define([_PKG_CONFIG],
++[if test -n "$PKG_CONFIG"; then
++    if test -n "$$1"; then
++        pkg_cv_[]$1="$$1"
++    else
++        PKG_CHECK_EXISTS([$3],
++                         [pkg_cv_[]$1=`$PKG_CONFIG --[]$2 "$3" 2>/dev/null`],
++                       [pkg_failed=yes])
++    fi
++else
++      pkg_failed=untried
++fi[]dnl
++])# _PKG_CONFIG
++
++# _PKG_SHORT_ERRORS_SUPPORTED
++# -----------------------------
++AC_DEFUN([_PKG_SHORT_ERRORS_SUPPORTED],
++[AC_REQUIRE([PKG_PROG_PKG_CONFIG])
++if $PKG_CONFIG --atleast-pkgconfig-version 0.20; then
++        _pkg_short_errors_supported=yes
++else
++        _pkg_short_errors_supported=no
++fi[]dnl
++])# _PKG_SHORT_ERRORS_SUPPORTED
++
++
++# PKG_CHECK_MODULES(VARIABLE-PREFIX, MODULES, [ACTION-IF-FOUND],
++# [ACTION-IF-NOT-FOUND])
++#
++#
++# Note that if there is a possibility the first call to
++# PKG_CHECK_MODULES might not happen, you should be sure to include an
++# explicit call to PKG_PROG_PKG_CONFIG in your configure.ac
++#
++#
++# --------------------------------------------------------------
++AC_DEFUN([PKG_CHECK_MODULES],
++[AC_REQUIRE([PKG_PROG_PKG_CONFIG])dnl
++AC_ARG_VAR([$1][_CFLAGS], [C compiler flags for $1, overriding pkg-config])dnl
++AC_ARG_VAR([$1][_LIBS], [linker flags for $1, overriding pkg-config])dnl
++
++pkg_failed=no
++AC_MSG_CHECKING([for $1])
++
++_PKG_CONFIG([$1][_CFLAGS], [cflags], [$2])
++_PKG_CONFIG([$1][_LIBS], [libs], [$2])
++
++m4_define([_PKG_TEXT], [Alternatively, you may set the environment variables $1[]_CFLAGS
++and $1[]_LIBS to avoid the need to call pkg-config.
++See the pkg-config man page for more details.])
++
++if test $pkg_failed = yes; then
++        _PKG_SHORT_ERRORS_SUPPORTED
++        if test $_pkg_short_errors_supported = yes; then
++              $1[]_PKG_ERRORS=`$PKG_CONFIG --short-errors --errors-to-stdout --print-errors "$2"`
++        else 
++              $1[]_PKG_ERRORS=`$PKG_CONFIG --errors-to-stdout --print-errors "$2"`
++        fi
++      # Put the nasty error message in config.log where it belongs
++      echo "$$1[]_PKG_ERRORS" >&AS_MESSAGE_LOG_FD
++
++      ifelse([$4], , [AC_MSG_ERROR(dnl
++[Package requirements ($2) were not met:
++
++$$1_PKG_ERRORS
++
++Consider adjusting the PKG_CONFIG_PATH environment variable if you
++installed software in a non-standard prefix.
++
++_PKG_TEXT
++])],
++              [AC_MSG_RESULT([no])
++                $4])
++elif test $pkg_failed = untried; then
++      ifelse([$4], , [AC_MSG_FAILURE(dnl
++[The pkg-config script could not be found or is too old.  Make sure it
++is in your PATH or set the PKG_CONFIG environment variable to the full
++path to pkg-config.
++
++_PKG_TEXT
++
++To get pkg-config, see <http://pkg-config.freedesktop.org/>.])],
++              [$4])
++else
++      $1[]_CFLAGS=$pkg_cv_[]$1[]_CFLAGS
++      $1[]_LIBS=$pkg_cv_[]$1[]_LIBS
++        AC_MSG_RESULT([yes])
++      ifelse([$3], , :, [$3])
++fi[]dnl
++])# PKG_CHECK_MODULES
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -1,4 +1,4 @@
+-ACLOCAL_AMFLAGS = -I shave
++ACLOCAL_AMFLAGS = -I shave -I m4
+ SUBDIRS = libbb libopkg src tests utils man
diff --git a/package/opkg/patches/002-no-shave.patch b/package/opkg/patches/002-no-shave.patch
new file mode 100644 (file)
index 0000000..313aa71
--- /dev/null
@@ -0,0 +1,37 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -4,7 +4,6 @@ AC_CONFIG_SRCDIR([libopkg/pkg.c])
+ AC_CONFIG_AUX_DIR([conf])
+ AC_CONFIG_MACRO_DIR([m4])
+-AC_CONFIG_MACRO_DIR([shave])
+ AM_INIT_AUTOMAKE
+ AM_CONFIG_HEADER(libopkg/config.h)
+@@ -277,9 +276,6 @@ AC_SUBST(opkgetcdir)
+ AC_SUBST(opkglockfile)
+ AC_SUBST([CLEAN_DATE])
+-# Setup output beautifier.
+-SHAVE_INIT([shave], [enable])
+-
+ AC_OUTPUT(
+     Makefile
+     libopkg/Makefile
+@@ -289,8 +285,6 @@ AC_OUTPUT(
+     utils/Makefile
+     utils/update-alternatives
+     libopkg.pc
+-    shave/shave
+-    shave/shave-libtool
+     man/Makefile
+     man/opkg-cl.1
+     man/opkg-key.1
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -1,4 +1,4 @@
+-ACLOCAL_AMFLAGS = -I shave -I m4
++ACLOCAL_AMFLAGS = -I m4
+ SUBDIRS = libbb libopkg src tests utils man
diff --git a/package/opkg/patches/009-remove-upgrade-all.patch b/package/opkg/patches/009-remove-upgrade-all.patch
new file mode 100644 (file)
index 0000000..3bd7659
--- /dev/null
@@ -0,0 +1,41 @@
+--- a/libopkg/opkg_cmd.c
++++ b/libopkg/opkg_cmd.c
+@@ -508,18 +508,6 @@ opkg_upgrade_cmd(int argc, char **argv)
+                           err = -1;
+                }
+         }
+-     } else {
+-        pkg_vec_t *installed = pkg_vec_alloc();
+-
+-        pkg_info_preinstall_check();
+-
+-        pkg_hash_fetch_all_installed(installed);
+-        for (i = 0; i < installed->len; i++) {
+-             pkg = installed->pkgs[i];
+-             if (opkg_upgrade_pkg(pkg))
+-                     err = -1;
+-        }
+-        pkg_vec_free(installed);
+      }
+      if (opkg_configure_packages(NULL))
+@@ -1215,7 +1203,7 @@ opkg_print_architecture_cmd(int argc, ch
+    array for easier maintenance */
+ static opkg_cmd_t cmds[] = {
+      {"update", 0, (opkg_cmd_fun_t)opkg_update_cmd, PFM_DESCRIPTION|PFM_SOURCE},
+-     {"upgrade", 0, (opkg_cmd_fun_t)opkg_upgrade_cmd, PFM_DESCRIPTION|PFM_SOURCE},
++     {"upgrade", 1, (opkg_cmd_fun_t)opkg_upgrade_cmd, PFM_DESCRIPTION|PFM_SOURCE},
+      {"list", 0, (opkg_cmd_fun_t)opkg_list_cmd, PFM_SOURCE},
+      {"list_installed", 0, (opkg_cmd_fun_t)opkg_list_installed_cmd, PFM_SOURCE},
+      {"list-installed", 0, (opkg_cmd_fun_t)opkg_list_installed_cmd, PFM_SOURCE},
+--- a/src/opkg-cl.c
++++ b/src/opkg-cl.c
+@@ -214,7 +214,7 @@ usage()
+       printf("\nPackage Manipulation:\n");
+       printf("\tupdate                        Update list of available packages\n");
+-      printf("\tupgrade                       Upgrade installed packages\n");
++      printf("\tupgrade <pkgs>                Upgrade packages\n");
+       printf("\tinstall <pkgs>                Install package(s)\n");
+       printf("\tconfigure <pkgs>      Configure unpacked package(s)\n");
+       printf("\tremove <pkgs|regexp>  Remove package(s)\n");
diff --git a/package/opkg/patches/014-errors-to-stderr.patch b/package/opkg/patches/014-errors-to-stderr.patch
new file mode 100644 (file)
index 0000000..f0a93a8
--- /dev/null
@@ -0,0 +1,15 @@
+--- a/libopkg/opkg_message.c
++++ b/libopkg/opkg_message.c
+@@ -64,10 +64,10 @@ print_error_list(void)
+       struct errlist *err = error_list_head;
+       if (err) {
+-              printf("Collected errors:\n");
++              fprintf(stderr, "Collected errors:\n");
+               /* Here we print the errors collected and free the list */
+               while (err != NULL) {
+-                      printf(" * %s", err->errmsg);
++                      fprintf(stderr, " * %s", err->errmsg);
+                       err = err->next;
+               }
+       }