[backfire] merge r25627
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 20 Feb 2011 18:27:58 +0000 (18:27 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 20 Feb 2011 18:27:58 +0000 (18:27 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/backfire@25628 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/6in4/Makefile
package/6in4/files/6in4.hotplug

index f5d3dfc84d7dfed62477245bf3a4080c1b98c52f..60dce9faf7e7e3f90d196d7a767e3f7b7b3121c7 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=6in4
-PKG_VERSION:=8
+PKG_VERSION:=9
 PKG_RELEASE:=1
 
 include $(INCLUDE_DIR)/package.mk
index 9499296d92c21cad53258a59b41f36f24faa5643..49667a815e1caa1a9aaf5b91b4eb8cbedb91880f 100644 (file)
@@ -29,11 +29,12 @@ if [ "$ACTION" = ifup ]; then
                        local password
                        config_get password "$cfg" password
 
+                       uci_set_state network "$cfg" ipaddr "$wanip"
+
                        [ -n "$tunnelid" ] && [ -n "$username" ] && [ -n "$password" ] && {
                                [ "${#password}" == 32 -a -z "${password//[a-f0-9]/}" ] || {
                                        password="$(echo -n "$password" | md5sum)"; password="${password%% *}"
                                }
-                               uci_set_state network "$cfg" ipaddr "$wanip"
 
                                (
                                        local url="http://ipv4.tunnelbroker.net/ipv4_end.php?ipv4b=AUTO&user_id=$username&pass=$password&tunnel_id=$tunnelid"
@@ -51,6 +52,9 @@ if [ "$ACTION" = ifup ]; then
                                                }
                                        done
                                )&
+                       } || {
+                               logger -t 6in4-update "Re-establishing tunnel due to change on $INTERFACE ($DEVICE)"
+                               ifup "$cfg" &
                        }
                }
        }