[package] e2fsprogs: use select-style dependencies, don't ship dev shlib symlink
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 21 Dec 2009 00:59:14 +0000 (00:59 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 21 Dec 2009 00:59:14 +0000 (00:59 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@18866 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/e2fsprogs/Makefile

index c05105aab7658781a4f5c807edaed907d2129267..bf744147bb9b2792553a764c459d6ea2d7821ea5 100644 (file)
@@ -49,7 +49,7 @@ endef
 
 define Package/uuidgen
 $(call Package/e2fsprogs)
-  DEPENDS:=libuuid
+  DEPENDS:=+libuuid
   TITLE:=Command line utility to create a new UUID value
 endef
 
@@ -86,25 +86,25 @@ endef
 define Package/tune2fs
 $(call Package/e2fsprogs)
   TITLE:=Ext2 Filesystem tune utility
-  DEPENDS:=e2fsprogs
+  DEPENDS:= +e2fsprogs
 endef
 
 define Package/resize2fs
 $(call Package/e2fsprogs)
   TITLE:=Ext2 Filesystem resize utility
-  DEPENDS:=e2fsprogs
+  DEPENDS:= +e2fsprogs
 endef
 
 define Package/badblocks
 $(call Package/e2fsprogs)
   TITLE:=Ext2 Filesystem badblocks utility
-  DEPENDS:=e2fsprogs
+  DEPENDS:= +e2fsprogs
 endef
 
 define Package/blkid
 $(call Package/e2fsprogs)
   TITLE:=Command-line utility to locate/print block device attributes
-  DEPENDS:=libuuid libblkid
+  DEPENDS:=+libuuid +libblkid
 endef
 
 TARGET_CFLAGS += $(FPIC)
@@ -177,7 +177,7 @@ endef
 
 define Package/libext2fs/install
        $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libext2fs.so* $(1)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libext2fs.so.* $(1)/usr/lib/
 endef
 
 define Package/tune2fs/install