[backfire] merge r21489-r21494
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 28 May 2010 00:41:57 +0000 (00:41 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 28 May 2010 00:41:57 +0000 (00:41 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/backfire@21592 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/base-files/files/etc/hotplug.d/net/10-net
package/base-files/files/usr/share/udhcpc/default.script
package/busybox/files/cron
package/uci/Makefile
package/uci/files/lib/config/uci.sh
package/uhttpd/files/uhttpd.init

index ef590046452ecfdceb9e0c8e0f04952e41bdd12b..42ff29e799684fd6aef4063b9adacb2594d4fd95 100644 (file)
@@ -46,7 +46,7 @@ delif() {
        for ifc in $interfaces; do
                config_get iftype "$ifc" type
                config_get ifs "$ifc" device
-               confdevs="$(uci get network.$ifc.ifname)"
+               confdevs="$(uci_get network.$ifc.ifname)"
                for dev in $ifs; do
                        [ "${dev%%\.*}" = "$INTERFACE" ] && {
                                list_contains confdevs "$dev" || list_remove ifs "$dev"
index b32b2c9f256e5c941f2fe0e5fd0f98399ded6dad..ceabf4bf3a3074de78a8ef6fe09b93b6d6f7ff9a 100755 (executable)
@@ -11,11 +11,6 @@ change_state () {
        uci_set_state "$1" "$2" "$3" "$4"
 }
 
-uci_get() {
-       [ -n "$ifc" ] || return
-       uci -P /dev/null get "$1" 2>/dev/null
-}
-
 setup_interface () {
        local old_ip
        local old_broadcast
index 2e020bbc629a9995eb7be7b98359dac9cc6965ff..d997937092d1d0b39ec6f2b0613a9d6d58379b94 100755 (executable)
@@ -3,7 +3,7 @@
 START=50
 
 start () {
-       loglevel=$(/sbin/uci get "system.@system[0].cronloglevel" 2>/dev/null)
+       loglevel=$(uci_get "system.@system[0].cronloglevel")
        [ -z "$(ls /etc/crontabs/)" ] && exit 1
        mkdir -p /var/spool/cron
        ln -s /etc/crontabs /var/spool/cron/ 2>/dev/null
index 3ce9e9ee3887939e2573dc7745dabf89a386485c..bf0107f7772a91651e73386e55de3c7a230a3082 100644 (file)
@@ -12,7 +12,7 @@ UCI_RELEASE=5
 
 PKG_NAME:=uci
 PKG_VERSION:=$(UCI_VERSION)$(if $(UCI_RELEASE),.$(UCI_RELEASE))
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 PKG_REV:=aa3ab8012bfbf793d2884c08ea924545a04e9544
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
index 851a0d779baaddec836d51bc0e1dc9c64a524533..d759615bd5f0376bbc2c5043aa85a667e1be71ce 100644 (file)
@@ -1,6 +1,7 @@
 #!/bin/sh
 # Shell script compatibility wrappers for /sbin/uci
 #
+# Copyright (C) 2008-2010  OpenWrt.org
 # Copyright (C) 2008  Felix Fietkau <nbd@openwrt.org>
 #
 # This program is free software; you can redistribute it and/or modify
@@ -41,9 +42,9 @@ uci_load() {
 
 uci_set_default() {
        local PACKAGE="$1"
-       /sbin/uci ${UCI_CONFIG_DIR:+-c $UCI_CONFIG_DIR} -q show "$1" > /dev/null && return 0
-       /sbin/uci ${UCI_CONFIG_DIR:+-c $UCI_CONFIG_DIR} import "$1"
-       /sbin/uci ${UCI_CONFIG_DIR:+-c $UCI_CONFIG_DIR} commit "$1"
+       /sbin/uci ${UCI_CONFIG_DIR:+-c $UCI_CONFIG_DIR} -q show "$PACKAGE" > /dev/null && return 0
+       /sbin/uci ${UCI_CONFIG_DIR:+-c $UCI_CONFIG_DIR} import "$PACKAGE"
+       /sbin/uci ${UCI_CONFIG_DIR:+-c $UCI_CONFIG_DIR} commit "$PACKAGE"
 }
 
 uci_revert_state() {
@@ -73,6 +74,23 @@ uci_set() {
        /sbin/uci ${UCI_CONFIG_DIR:+-c $UCI_CONFIG_DIR} set "$PACKAGE.$CONFIG.$OPTION=$VALUE"
 }
 
+uci_get_state() {
+       uci_get "$1" "$2" "$3" "$4" "/var/state"
+}
+
+uci_get() {
+       local PACKAGE="$1"
+       local CONFIG="$2"
+       local OPTION="$3"
+       local DEFAULT="$4"
+       local STATE="$5"
+
+       /sbin/uci ${UCI_CONFIG_DIR:+-c $UCI_CONFIG_DIR} ${STATE:+-P $STATE} -q get "$PACKAGE${CONFIG:+.$CONFIG}${OPTION:+.$OPTION}"
+       RET="$?"
+       [ "$RET" -ne 0 ] && [ -n "$DEFAULT" ] && echo "$DEFAULT"
+       return "$RET"
+}
+
 uci_add() {
        local PACKAGE="$1"
        local TYPE="$2"
index 14f8fc4c468d79ebe2b171ab258fb99aca010273..58f980c42f2dc92696f1ddfa6cc8da4b40a71cfe 100755 (executable)
@@ -48,7 +48,7 @@ start_instance()
        UHTTPD_KEY=""
 
        local cfg="$1"
-       local realm="$(uci get system.@system[0].hostname 2>/dev/null)"
+       local realm="$(uci_get system.@system[0].hostname)"
        local listen http https
 
        append_arg "$cfg" home "-h"