[backfire] merge r25974
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 9 Mar 2011 14:45:58 +0000 (14:45 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 9 Mar 2011 14:45:58 +0000 (14:45 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/backfire@25975 3c298f89-4303-0410-b956-a3cf2f4a3e73

tools/Makefile
tools/xfce-macros/Makefile [new file with mode: 0644]

index 3f16ce5e5120e73caa8fa4abe39e78769c956718..5bf28a5f5ee9ef61640f7e91512dc92f0810c38f 100644 (file)
@@ -16,7 +16,7 @@ endif
 tools-y += m4 libtool autoconf automake bison pkg-config sed mklibs
 tools-y += sstrip ipkg-utils genext2fs libuuid mtd-utils mkimage
 tools-y += firmware-utils patch-cmdline quilt yaffs2 xz cmake
 tools-y += m4 libtool autoconf automake bison pkg-config sed mklibs
 tools-y += sstrip ipkg-utils genext2fs libuuid mtd-utils mkimage
 tools-y += firmware-utils patch-cmdline quilt yaffs2 xz cmake
-tools-y += mm-macros xorg-macros missing-macros
+tools-y += mm-macros xorg-macros xfce-macros missing-macros
 tools-$(CONFIG_TARGET_orion) += wrt350nv2-builder upslug2
 tools-$(CONFIG_TARGET_x86) += qemu
 ifneq ($(CONFIG_LINUX_2_4)$(CONFIG_LINUX_2_6_25),)
 tools-$(CONFIG_TARGET_orion) += wrt350nv2-builder upslug2
 tools-$(CONFIG_TARGET_x86) += qemu
 ifneq ($(CONFIG_LINUX_2_4)$(CONFIG_LINUX_2_6_25),)
@@ -50,6 +50,7 @@ $(curdir)/qemu/compile := $(curdir)/libuuid/install
 $(curdir)/upslug2/compile := $(curdir)/automake/install
 $(curdir)/mm-macros/compile := $(curdir)/automake/install
 $(curdir)/xorg-macros/compile := $(curdir)/automake/install
 $(curdir)/upslug2/compile := $(curdir)/automake/install
 $(curdir)/mm-macros/compile := $(curdir)/automake/install
 $(curdir)/xorg-macros/compile := $(curdir)/automake/install
+$(curdir)/xfce-macros/compile := $(curdir)/automake/install
 $(curdir)/missing-macros/compile := $(curdir)/automake/install
 
 $(curdir)/builddirs := $(tools-y) $(tools-dep) $(tools-)
 $(curdir)/missing-macros/compile := $(curdir)/automake/install
 
 $(curdir)/builddirs := $(tools-y) $(tools-dep) $(tools-)
diff --git a/tools/xfce-macros/Makefile b/tools/xfce-macros/Makefile
new file mode 100644 (file)
index 0000000..bd71913
--- /dev/null
@@ -0,0 +1,32 @@
+#
+# Copyright (C) 2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=xfce-macros
+PKG_VERSION:=4.8.0
+
+PKG_SOURCE_URL:=http://archive.xfce.org/xfce/4.8/src
+PKG_SOURCE:=xfce4-dev-tools-$(PKG_VERSION).tar.bz2
+PKG_MD5SUM:=9591299c49d92d00ba47974c42a735fa
+
+HOST_BUILD_DIR:=$(BUILD_DIR)/xfce4-dev-tools-$(PKG_VERSION)
+
+include $(INCLUDE_DIR)/host-build.mk
+
+define Host/Configure
+endef
+
+define Host/Compile
+endef
+
+define Host/Install
+       $(INSTALL_DIR) $(STAGING_DIR_HOST)/share/aclocal
+       $(INSTALL_DATA) $(HOST_BUILD_DIR)/m4macros/*.m4 $(STAGING_DIR_HOST)/share/aclocal/
+endef
+
+$(eval $(call HostBuild))