merge the kernel config parts at dump time, so that overrides that disable certain...
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 30 Jun 2007 21:49:25 +0000 (21:49 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 30 Jun 2007 21:49:25 +0000 (21:49 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@7812 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/kernel-build.mk

index 83d0d5e6ebffbe12856db6c55cb66d30c89cf995..40884220883c371fdc2d351b1a2094b22f3b0531 100644 (file)
@@ -15,8 +15,13 @@ GENERIC_LINUX_CONFIG:=$(GENERIC_PLATFORM_DIR)/config-$(shell [ -f "$(GENERIC_PLA
 LINUX_CONFIG_DIR ?= ./config$(shell [ -d "./config-$(KERNEL_PATCHVER)" ] && printf -- "-$(KERNEL_PATCHVER)" || true )
 LINUX_CONFIG ?= $(LINUX_CONFIG_DIR)/default
 
--include $(GENERIC_LINUX_CONFIG)
--include $(LINUX_CONFIG)
+ifneq ($(DUMP),)
+  TMP_CONFIG:=$(TMP_DIR)/.kconfig-$(BOARD)-$(KERNEL)
+  $(TMP_CONFIG): $(GENERIC_LINUX_CONFIG) $(LINUX_CONFIG)
+       $(SCRIPT_DIR)/config.pl + $^ > $@
+  -include $(TMP_CONFIG)
+  .SILENT: $(TMP_CONFIG)
+endif
 
 ifneq ($(CONFIG_ATM),)
   FEATURES += atm