[package] base-files: disable bridge firewalling by default
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 18 Jan 2010 05:38:44 +0000 (05:38 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 18 Jan 2010 05:38:44 +0000 (05:38 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@19214 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/base-files/Makefile
package/base-files/files/etc/sysctl.conf

index ea2b5a47f196adf842c82c503b73e8d1f2e88cd3..fb30b94ab98ce780fc990a1ed17fa4290c5f22dd 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007-2009 OpenWrt.org
+# Copyright (C) 2007-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=base-files
-PKG_RELEASE:=35
+PKG_RELEASE:=36
 
 PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
 
index 63497beb1c30c001bdf95f7293fd47e9fa6ec04b..759752ae5e6c006501745e787203bf4980e7e48d 100644 (file)
@@ -4,7 +4,7 @@ net.ipv4.conf.all.arp_ignore=1
 net.ipv4.ip_forward=1
 net.ipv4.icmp_echo_ignore_broadcasts=1
 net.ipv4.icmp_ignore_bogus_error_responses=1
-net.ipv4.tcp_ecn=0 
+net.ipv4.tcp_ecn=0
 net.ipv4.tcp_fin_timeout=30
 net.ipv4.tcp_keepalive_time=120
 net.ipv4.tcp_syncookies=1
@@ -17,3 +17,8 @@ net.ipv4.netfilter.ip_conntrack_tcp_timeout_established=3600
 net.ipv4.netfilter.ip_conntrack_udp_timeout=60
 net.ipv4.netfilter.ip_conntrack_udp_timeout_stream=180
 # net.ipv6.conf.all.forwarding=1
+
+# disable bridge firewalling by default
+net.bridge.bridge-nf-call-arptables=0
+net.bridge.bridge-nf-call-ip6tables=0
+net.bridge.bridge-nf-call-iptables=0